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Chapter 1 — Setup Instructions

INTRODUCTION TO APP INVENTOR 2

App Inventor for Android is an open-source web application originally provided by Google, and now
maintained by the Massachusetts Institute of Technology (MIT).

“; = MIT

APP INVENTOR

It is a programming environment that allows newcomers to computer programming to create software
applications for the Android operating system. It uses a graphical interface, very similar to Scratch,
which allows users to drag-and-drop visual objects to create an application that can run on Android
devices.
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SETTING UP APP INVENTOR 2

We can set up App Inventor and start building apps in minutes. The Designer and Blocks Editor
run completely in the browser.

To see our app on a device while we build it (also called "Live Testing"), we have three options:
e We use an Android Device (with WiFi Connection)
e We use an Android Device (with USB Connection)

e We use the Emulator of App Inventor
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Build your project on Test it in real-time on
your computer your device

If we are using an Android device and we have a wireless internet connection, we can start building
apps without downloading any software to our computer. We will develop apps on the
website: ai2.appinventor.mit.edu.

To do live testing on our Android device, we must install the MIT App Inventor Companion app on our
Android phone or tablet. Once the Companion is installed, we can open projects in App Inventor on
the web, open the companion on our device, and we can test our apps as we build them:

MIT Al2 Companion

MIT Center for Mobile Learning Education
E recis
.

The following steps will drive us through this process:
Step 1: Download the MIT Al2 Companion App from the Play Store and install it on your phone.

To do that, we can open our device's QR code scanner and scan the QR code below to download the
Companion App from the Play Store.

We need to install the MIT Al2 Companion only once, and then leave it on our phone or tablet for
whenever we use App Inventor.

If we are unable to use the QR code, we can still install MIT Al2 Companion on our phone
or tablet. We use the Play Store app on our device to go to the Google Play Store. Then we
look for MIT AI2 Companion in the store. Once we find Companion, we click the INSTALL
button for the Companion app.

Step 2: Connect both your computer and your device to the SAME WiFi Network

App Inventor will automatically show us the app we are building, but only if our computer (running
App Inventor) and our Android device (running the Companion) are connected to the same WiFi
Network.
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Step 3: Open an App Inventor project and connect it to your device

We go to App Inventor and open a project (or we create a new one by using Project > Start New
Project and give our project a name).

Then, we choose "Connect" and "Al Companion" from the top menu in the Al2 browser:

09 MIT

B9 APP INVENTOR

Emulator

Projects Connect v Build ~ Help » My Projects Gallery Guide Rejl

Palette Viewer ‘ UsB Components

User Interface Reset Connection components in Viewer | Screent

Hard Reset freview on Tablet size
. Button

W CheckBox

DatePicker

4 Image

A dialog with a QR code will appear on our PC screen. On our device, we launch the MIT App
Companion app just as we would do any app. Then, we click the “Scan QR code” button on the
Companion, and scan the code in the App Inventor window:

MI‘I'Applnvemor2Car::znion LS

MIT App Inventor 2

Connect to Companion

Launch the MIT Al2 Companion on your device
and then scan the barcode or type in the code
to connect for live testing of your app.

Need help finding the Companion App?

!;E: Your codeiy

gktpmz

scan QR code

Your IP Address is: 192.168.1.105
Version: 2.27

Cancel

Within a few seconds, we should see the app we are building on our device. It will update as we make
changes to our design and blocks, a feature called “live testing”.

If we have trouble scanning the QR code or our device does not have a scanner, we type the code
shown on the computer into the Companion's text area on our Android device exactly as shown.

The code is directly below where the screen on our PC shows "Your code is" and consists of six
characters. We type the six characters and choose the orange "Connect with code". We should not

type an Enter or carriage return. We type just the six characters followed by pressing the orange
button.

If our app does not appear on our device, the most likely problems are:

e We may have an outdated version of the App Inventor Companion App. So, we download the
latest Companion App for App Inventor 2.
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Our device may not be connected to wifi. So, we make sure we see an IP address at the bottom
of the Al Companion App screen on our phone or tablet.

Our device may not be connected to the same wifi network as our computer. So, we make sure
both devices are connected to the same wifi network name.

Build apps with an Android device and USB Cable

Some firewalls within schools and organizations do not allow the type of WiFi connection required. If
WiFi doesn’t work for us, we try USB.

Build your project on Test it in real-time on
your computer your device

When we use App Inventor with a phone or tablet, that device communicates with the App Inventor
software running in our computer's browser window. This communication is managed by the Al2
Companion App running on the device. The Companion can communicate with our computer over a
wireless connection. This is the method strongly recommended by the App Inventor team. It does not
require any additional software to be installed on our computer.

There are, however, some environments where wireless connections won't work. These include some
hotels, conference centers, and schools, that configure their wireless networks to prohibit two devices
on the network from communicating with each other.

Setting up a USB connection can be awkward, especially on Windows machines, which need
special driver software to connect to Android devices. (This is not the case with Mac or Linux, which do
not need special drivers.)

The following steps are needed to use App Inventor with the USB cable:
Step 1: Install the App Inventor Setup Software

To connect with USB, we need to first install the App Inventor setup software on our computer. (This is
not required for the wifi method). Based on our operating system, we install the App Inventor Setup
software package (e.g. for Windows the installer is called MIT_Appinventor_Tools_2.3.0 and it is almost
80 MB).

%/ User Account Control

’ Do you want to allow the following program from an
unknown publisher to make changes to this computer?

Program name:  MIT_App_Inventor_Tools_2.3.0_win_setup.exe
Publisher: Unknown
File origin: Downloaded from the Internet

(v) Show details

Change when these notifications appear
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Step 2: Download the MIT AI2 Companion App from the Play Store and install it on your phone.

To do that, we can open our device's QR code scanner and scan the QR code below to download the
Companion App from the Play Store.

We need to install the MIT Al2 Companion only once, and then leave it on our phone or tablet for
whenever we use App Inventor.

If we are unable to use the QR code, we can still install MIT Al2 Companion on our phone
or tablet. We use the Play Store app on our device to go to the Google Play Store. Then we
look for MIT Al2 Companion in the store. Once we find Companion, we click the INSTALL
button for the Companion app.

Step 3. Launch aiStarter (Windows & GNU/Linux only)

Using the emulator or the USB cable requires the use of a program named aiStarter. This program is
the helper that permits the browser to communicate with the emulator or USB cable.

The aiStarter program was installed when we installed the App Inventor Setup package. We do not
need aiStarter if we are using only the wireless companion.

On a Mag, aiStarter will start automatically when we log in to our account and it will run invisibly in the
background.

On Windows, there will be shortcuts to aiStarter from our Desktop, from the Start menu,
from All Programs and from Startup Folder. We can start aiStarter this by clicking the icon
on our desktop or using the entry in our start menu.

To launch aiStarter on Windows, we double click on the icon (shown above). We will know that we
have successfully launched aiStarter when we see a window like the following:

W] aiStarter

located here: "C:n\Program Files {(x86>"
Bottle server starting up (using WEGIRefServer(l)...
Listening on http:~/-/127.0.0.1:80084~
Hit Ctrl-C to guit.
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Step 4: Set up your device for USB (Turn USB Debugging ON)

On our Android device, we go to System Settings, Developer Options, turn them on, and be sure that
"USB Debugging" is allowed.

On most devices running Android 3.2 or older, we can find this option under Settings > Applications >
Development.

On Android 4.0 and newer, it's in Settings > Developer options.

Note: On Android 4.2 and newer, Developer options is hidden by default. To make it available, we go
to Settings > About phone and tap Build number seven times. Then, we return to the previous screen
to find Developer options, including "USB Debugging".

Step 5: Connect your computer and device, and authenticate if necessary.

We connect our Android device to the computer using the USB cable being sure that the device
connects as a "mass storage device" (not "media device") and that it is not mounted as a drive on our
computer. This may mean that we have to go to the Finder (on a Mac) or My Computer (on Windows)
and disconnect any drive(s) that were mounted when we connected your Android device.

On Android 4.2.2 and newer, our device will pop up a screen with the message Allow USB
Debugging? the first time we connect it to new computer. We press "OK". This authenticates the
computer to the device, allowing the computer to communicate with it. We'll need to do this for each
computer we want to connect to the device, but only once per computer.

Build apps with the Emulator

If we do not have an Android phone or tablet, we can still build apps with App Inventor. App Inventor
provides an Android emulator, which works just like an Android but appears on our computer screen.
So, we can test our apps on an emulator and still distribute the app to others, even through the Play

Store.

Build your project on Test it in real-time on
your computer your computer with
the onscreen
emulator

The following steps are needed to use App Inventor with the Android Emulator:

Step 1: Install the App Inventor Setup Software

To connect with emulator, we need to first install the App Inventor setup software on our computer.
(This is not required for the wifi method). Based on our operating system, we install the App Inventor
Setup software package (e.g. for Windows the installer is called MIT_Appinventor_Tools_2.3.0 and it is
almost 80 MB).
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% User Account Control

: ' Do you want to allow the following program from an
2/ unknown publisher to make changes to this computer?

Program name:  MIT_App_Inventor_Tools_2.3.0_win_setup.exe
Publisher: Unknown
File origin: Downloaded from the Internet

(v) Show details

Change when these notifications appear

Step 2: Download the MIT Al2 Companion App from the Play Store and install it on your phone.

To do that, we can open our device's QR code scanner and scan the QR code below to download the
Companion App from the Play Store.

We need to install the MIT Al2 Companion only once, and then leave it on our phone or tablet for
whenever we use App Inventor.

If we are unable to use the QR code, we can still install MIT Al2 Companion on our phone
or tablet. We use the Play Store app on our device to go to the Google Play Store. Then we
look for MIT AI2 Companion in the store. Once we find Companion, we click the INSTALL
button for the Companion app.

Step 3. Launch aiStarter (Windows & GNU/Linux only)

Using the emulator or the USB cable requires the use of a program named aiStarter. This program is
the helper that permits the browser to communicate with the emulator or USB cable.

The aiStarter program was installed when we installed the App Inventor Setup package. We do not
need aiStarter if we are using only the wireless companion.

On a Mag, aiStarter will start automatically when we log in to our account and it will run invisibly in the

background.

On Windows, there will be shortcuts to aiStarter from our Desktop, from the Start menu,
from All Programs and from Startup Folder. We can start aiStarter this by clicking the icon
on our desktop or using the entry in our start menu. S15tETEn

To launch aiStarter on Windows, we double click on the icon (shown above). We will know that we
have successfully launched aiStarter when we see a window like the following:
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W] aiStarter

FPlatform = Windows

AppInventor tools located here: "C:“Program Fileszs (x86>"
Bottle server starting up Cusing WEGIRefServer(d)d...
Listening on http:--127.06.8.1:8884~

Hit Ctrl-C to guit.

Step 3. Open an App Inventor project and connect it to the emulator

First, we go to App Inventor and open a project (or create a new one -- use Project > Start New
Project and give our project a name).

Then, from App Inventor's menu, we go to the Connect Menu and click the Emulator option.

Projects v Connect v Build v Help v
APP INVENTOR

1 .
B - Al Companion
| doodle Screenl ~ P

Viewer USB

We'll get a notice saying that the emulator is connecting. Starting the emulator can take a couple of
minutes. We may see update screens like the following as the emulator starts up:

Emulator started, w 0 seconds to ensure all is running

Cancel

an 5554:<build>

The emulator will initially appear with an empty black screen. We should wait until
the emulator is ready, with a colored screen background.

Even after the background appears, we should wait until the emulated phone has
finished preparing its SD card: there will be a notice at the top of the phone screen
while the card is being prepared.

When connected, the emulator will launch and show the app we have open in App
Inventor.
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MIT App Inventor 2 Companion
Android

MIT App Inventor 2
1019

Running In the emulator, waiting to get blocks...
Tuesday, July 2

€ Charging (50%)

Note: If this is the first time we are using the emulator after installing the App Inventor Setup software,
we will see a message asking us to update the emulator. We follow the directions on the screen to
perform the update and reconnect the emulator. We will need to do this kind of update whenever
there is a new version of the App Inventor software.

COMPUTER AND OPERATING SYSTEM REQUIREMENTS
Macintosh (with Intel processor): Mac OS X 10.5 or higher
Windows: Windows XP, Windows Vista, Windows 7, Windows 10

GNU/Linux: Ubuntu 8 or higher, Debian 5 or higher (Note: GNU/Linux live development is only
supported for WiFi connections between computer and Android device.)

BROWSER REQUIREMENTS

Mozilla Firefox 3.6 or higher

(Note: If we are using Firefox with the NoScript extension, you'll need to turn the extension off.)

Apple Safari 5.0 or higher
Google Chrome 4.0 or higher

Microsoft Internet Explorer is not supported

PHONE OR TABLET REQUIREMENTS

Android Operating System 2.3 or higher.
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Chapter 2 — Designer & Blocks Editor

APP INVENTOR 2 INTERFACE

App Inventor consists of the Designer and the Blocks Editor. These are different areas inside the
interface that are described in detail below.

DESIGNER

It is the area into which we can design the App's User Interface by arranging both on- and off-screen
components. It consists of 4 sections:

Palette: Here, we find our components and drag them to the Viewer to add them to our app.

Viewer: Here, we can drag the components from the Palette to see what our app will look like.

Components: Here, we see a list with all the components we have added inside our app.

Properties: Here, we can change the properties of any component selected from the list.

M MIT
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BLOCKS EDITOR

It is the area into which we can program the app’s behavior by putting blocks together. It consists of 2
sections:

e Blocks: Here, we find our blocks needed to program the app. These blocks are classified into

2 categories: Built-In Drawers and Component-Specific Drawers.

Built-In Drawers: Here, we find blocks for general behaviors we may want to add to
our app and add them to the Blocks Viewer.

Component-Specific Drawers: Here, we can find blocks for behaviors for specific
components and drag them to the Blocks Viewer.

e Blocks Viewer: In here we drag the blocks from the drawers to build relationships and

behavior. We should snap blocks together to set app behaviors.
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Chapter 3 — Sharing & Packaging Apps

SHARING APPS

We can share our app in an executable form (.apk) that can be installed on a device, or in source code
form (.aia) that can be loaded into App Inventor and remixed. We can also distribute our app on
the Google Play Store.

Sharing our Source Code (.aia file)

First, we choose from the menu Projects > My Projects to view the list with all our projects. Then, we
select the project we wish to share by checking the box next to it.

Then, we choose Project > Export selected project (.aia) to my computer to export the source code
(blocks) for our project. The source code is downloaded in a .aia file.

A MIT

JS5. APP INVENTOR

. . . My projects
Start new project | Delete Project § Publif ¥ proJ

J Start new project

Projects Connect v Build Help ~

lnin Import project (.aia) from my computer ... L

Name A Import project (.aia) from a repository ... eated
app_001_the_cat Delete Project }, 2016, 4:48:34 PM
app_002_hello_students }, 2016, 4:49:36 PM
app_003_talk_to_me Save project 3, 2016, 4:50:58 PM
app_004_ball_bounce Save project as ... ), 2016, 4:59:47 PM
app_004_ball_bounce_01 Checkpoint , 2016, 9:55:32 AM
app_005_digital_doodle ), 2016, 4:59:10 PM
app_005_digital_doodle_01 '. 2016, 1:07:26 PM
app_006_roll_dice Export all projects ), 2016, 4:58:26 PM
app_006_roll_dice_01 Import keystore ,2016,12:04:15 PM
app_006_roll_dice_02 , 2016, 12:23:02 PM
) Export keystore

app_006_roll_dice_03 , 2016, 12:38:09 PM
app_006_roll_dice_04 Delete keystore | 2016, 12:57:18 PM

If we send that file to a friend, they can open it with Project > Import project (.aia) from my computer.

‘." mIIPIIENTOR Projects v Connect Build ~ Help v

My projects
Start new project § Delete Project I Publﬂ ¥ P —

Start new project ‘

My Projects ‘ Import project (.aia) from my computer ...

NameA Import project (.aia) from a repository ... eated

app_001_the_cat 3, 2016, 4:48:34 PM
Delete Project
app_002_hello_students ), 2016, 4:49:36 PM

app_003_talk_to_me Save project 3, 2016, 4:50:58 PM
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Sharing our Executable Form (.apk file)

We can share our app for others to install on their phone/tablet. We can package the app (.apk file) by
going to the Build menu on the App Inventor toolbar. Here, we have to options to export the app:

If we select App (save .apk to my computer), a pop-up box should alert us that our download has
begun. The file will be downloaded into the “Downloads” folder of our hard disk.

Once the build completes, we can email the app (".apk" file) to our friends who can install it by
opening the email from their phone.

If we want to distribute it more widely, we can upload it to a website that both us and our friend can
access. We can also distribute our app on the Google Play Store.

89 MIT
=

APP INVENTOR Projects v Connect v Build ~ Help v

Screenl v Add Screen ...

! :
App ( provide QR code for .apk ) .

App ( save .apk to my computer ) J

Palette Viewer

The other option App (provide QR code for .apk) produces a scannable QR code that will download the
app for two hours. We can share this code with others, but they must use it within 2 hours of our
generating it.

0 MIT

APP INVENTOR

App ( save .apk to my computer )

Projects v Connect v Build Help

Palette Viewer

Compiling part 1

Barcode link for test

Note: this barcode is only valid for 2
hours. See the FAQ for info on how
to share your app with others.
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NOTE: Anyone installing our app (which is an ".apk" file) will need to change the setting on their phone
to allow installation of non-market applications:

To find this setting on versions of Android prior to 4.0, we go to Settings > Applications and then check
the box next to Unknown Sources.

For devices running Android 4.0 or above, we go to Settings > Security and then check the box next to
Unknown Sources and confirm our choice.

MIT App Inventor
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