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Legal Notices

© Innovative Interfaces Incorporated and/or its affiliates. All rights reserved. All
trademarks shown are the property of their respective owners.

The information contained herein is subject to change without notice and is not
warranted to be error-free. If you find any errors, please report them to us in writing.

The software and related documentation are provided under an agreement containing
restrictions on use and disclosure and are protected by intellectual property laws. Except
as expressly permitted in your agreement or allowed by law, you may not use, copy,
reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform,
publish, or display any part, in any form, or by any means. Reverse engineering,
disassembly, or decompilation of the software, unless required by law for
interoperability, is prohibited.
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Polaris Installation Notes

Important:
When the new Polaris release is installed on a workstation, the file path
changes from 6.2 to 6.3 as in the following examples:
C:\ProgramData\Polaris\6.3
C:\Program Files\Polaris\6.3
C:\Program Files (x86)\Polaris\6.3
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New and Modified Polaris Administration Settings

The following table lists the new and modified profiles, parameters, and permissions in
Polaris Administration.

Setting Purpose Level

New Permissions

Cataloging: Cata-
loging record sets:
Delete/Undelete

Adds the ability to permission the undelete of
Cataloging record sets that have been
marked for deletion.

Staff

Patron record
sets:
Delete/Undelete

Adds the ability to permission the undelete of
Patron record sets that have been marked for
deletion.

Staff

Leap: Setup Off-
line: Allow

Controls which users can complete the Leap
Offline installation.

System

System Admin-
istration: Modify
genders table:
Allow

Allows you to modify the new Database table,
Genders Table.

Staff, Workstation,
Permission Group

Item Bulk Change
Templates:
Access

Allows users to view and use the saved item
bulk change template data.

Staff, Workstation,
Permission Group

Item Bulk Change
Templates: Create

Allows users to create new saved bulk
change templates.

Staff, Workstation,
Permission Group

Item Bulk Change
Templates:
Modify

Allows users to modify existing saved bulk
change templates.

Staff, Workstation,
Permission Group

Item Bulk Change
Templates: Delete

Allows users to delete saved bulk change
item bulk change template data.

Staff, Workstation,
Permission Group

Use 'own' item
bulk change tem-
plates: Allow

Allows staff to 'own' item record bulk change
templates.

System
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Setting Purpose Level

New Profiles

Cataloging: Auto-
matically populate
authority heading
in Find Tool dur-
ing check head-
ings

Lets you enable or disable the automatic pop-
ulation of the heading in the Authority
Records - Heading Find Tool when checking
for duplicate headings.

System

PowerPAC: Title
Display: Number
of characters in
the Summary 
(Short)

Allows you to specify the maximum number
of characters of the Summary (Short) field
that are displayed in the brief and full search
results views for a title in the Polaris
PowerPAC.

Branch

PAC: Reset pass-
word link timeout
duration

Allows you to determine the time period (in
minutes) during which the reset password
link emailed to the patron remains active.

System, Library,
and Branch

Patron Services:
Retain deleted pat-
ron record sets.

Enables the system to retain deleted patron
record sets.

Systems

Cataloging: Retain
deleted cataloging
record sets

Enables the system to retain deleted cata-
loging record sets.

Systems

New Parameters

Request: Total
holds thresholds
include Inactive

Lets you specify whether inactive hold
requests count toward a patron's total holds
limit.

System

Patron Services:
Patron Regis-
tration Filter
genders

Allows you to manage gender drop down
lists.

Branch

Patron Services: Allows you to suppress gender tracking in
Staff Client and Leap.

Branch
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Setting Purpose Level

Patron registration
options

Modified Profiles

PAC: Patron
access options:
Self-registration:
Suppress gender
selection

Allows you to suppress gender in Self-Regis-
tration.

Branch

PAC: Patron
Access Options:
Login

Enable option to send patrons a reset pass-
word link.

Branch

Modified Parameters:

Credit Card Pay-
ment: Online Pay-
ment Settings:
Configure

A new JetPay option in the Payment pro-
cessing gateway list allows you to configure
Polaris to use JetPay for processing credit
card payments from PowerPAC.

Library, Branch
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MARC Updates Implemented in Polaris 6.3

The updates specified in the October 26, 2018 MARC technical notice were implemented
in Polaris 6.3.

https://www.loc.gov/marc/relators/tn181026src.html
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WebAdmin Updates

The tables below lists the most important new strings added in Polaris 6.3.

ExpressCheck Strings

Mnemonic String Text

EC_TEXT_FORGOTPASSWORD_1010 The e-mail could not be sent. Please con-
tact the library for assistance.

EC_TEXT_FORGOTPASSWORD_EMAIL_
HOURS

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} hours. If the
link is expired, request a new one: {2} If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator

EC_TEXT_FORGOTPASSWORD_EMAIL_
MINUTES

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} minutes. If the
link is expired, request a new one: {2}If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator

MobilePAC Strings

Mnemonic String Text

MP_ACCOUNTLOGON_RESET_SUCCESS Your password has been reset.

MP_CRUMBS_RESETPWD Reset Password

MP_HOLD_REQ_AVAIL_ERROR Hold Requests are not allowed for this



What's New in Polaris and Leap

© 2019 Innovative Interfaces, Inc.
Page 12

Mnemonic String Text

title

MP_MSG_FORGOTPASSWORD_EMAIL_
HOURS

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} hours. If the
link is expired, request a new one: {2} If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator

MP_MSG_FORGOTPASSWORD_EMAIL_
MINUTES

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} minutes. If the
link is expired, request a new one: {2} If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator

MP_MSG_FORGOTPASSWORD_INFO_
BARCODE_RESET

Your reset password link has expired.
Please submit your Barcode below to
request a new one.

MP_MSG_FORGOTPASSWORD_INFO_
USERNAME_RESET

Your reset password link has expired.
Please submit your Username or Barcode
below to request a new one.

PowerPAC Strings

Mnemonic String Text

PACML_DASH_CHILDFICTIONSERIES Children's Fiction Series

PACML_DASH_CHILDILLUSTRATED Children's Illustrated

PACML_DASH_DONATION Make a Donation

PACML_DASH_EARLYMIDDLE Early and Middle Grade Readers (sys
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Mnemonic String Text

cust)

PACML_DASH_HARDFICTION Hardcover Fiction

PACML_DASH_HARDNONFICTION Hardcover Non-Fiction

PACML_DASH_MASSMARKET Mass Market

PACML_DASH_MOSTCIRCAUTHORS Most Circ'd Authors

PACML_DASH_MOSTCIRCSUBJECTS Most Circ'd Subjects

PACML_DASH_MOSTCIRCTITLES Most Circ'd Titles

PACML_DASH_NEWTITLES New Titles

PACML_DASH_ONORDERITEMS On-Order Items

PACML_DASH_PAPERFICTION Trade Paperback Fiction

PACML_DASH_PAPERNONFICTION Trade Paperback Non-Fiction

PACML_DASH_YOUNGADULT Young Adult

PACML_FORGOTPASSWORD_1014 Your reset password link is invalid or has
expired. Please submit your Username or
Barcode below to request a new one.

PACML_FORGOTPASSWORD_1015 Your reset password link is invalid or has
expired. Please submit your Barcode
below to request a new one.

PACML_FORGOTPASSWORD_CONFIRM Confirm Password:

PACML_FORGOTPASSWORD_EMAIL_
HOURS

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} hours. If the
link is expired, request a new one: {2} If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator
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Mnemonic String Text

PACML_FORGOTPASSWORD_EMAIL_
MINUTES

Click on the following link to set/reset
your password: Reset Password Link: {0}
This link can be used to reset your pass-
word, and will expire in {1} minutes. If the
link is expired, request a new one: {2} If
you did not request to reset your pass-
word, please ignore this message. Sin-
cerely, Your Library System Administrator

PACML_FORGOTPASSWORD_INST Please create a new password. You will
then be directed to log in.

PACML_FORGOTPASSWORD_NEW New Password:

PACML_FORGOTPASSWORD_SHOW Show password

PACML_FORGOTPASSWORD_TITLE Reset Password

PACML_JETPAY_DONATION_NOTE Thank you for your Donation.

PACML_JETPAY_PAYMENT_NOTE Thank you for your payment.

PACML_JETPAY_TRANSACTION_ERR There is a problem with your payment.
Please contact the library for assistance.

PACML_LOGON_PASSWORDRESET Your password has been reset.

PACML_PROCESSINGFEES_JETPAY_ERR JetPay fee is $0.00 or there was a
JetPay API error. You will see the fee
when you are at the JetPay site.

PACML_SUMMARYLESS Less

PACML_SUMMARYMORE More
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Polaris API Changes

The table below is a list of changes to the Polaris APIs for v6.3.

Method Name Purpose

PickupBranchesGet This new endpoint returns a list of valid
pickup branches based on the organ-
ization ID.

ShelfLocationsGet This new endpoint returns a list of shelf
locations based on the organization ID.

Synch_BibsPagedGet This new endpoint allows a paged
extraction of bib record data.

ItemUpdateBarcode The new parameter BarcodeOrID has
been implemented that enables a bar-
code to be updated using either the item
ID or the item barcode as an identifier.
An additional new parameter, isBarcode,
specifies whether the identifier used is
an item record ID or a barcode.

PatronHoldRequestGet A new CanSuspend Boolean property
has been added that indicates whether
a patron’s hold request can be sus-
pended.

PatronReadingHistoryClear Now removes a range of historical read-
ing history entries by specifying their ID
using the new id query string parameter.

For more information, see the Polaris API Reference for v6.3.
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Bulk Update Purchase Order Notes

You now have the ability to update purchase order line item notes in bulk from the
Purchase Order workform.

The Update Note option is now in the right-click menu for purchase order line items. You
can select one or more notes to update with this option.

Note:
This menu option is not enabled if any of the selected purchase order line
items have a status of Closed.

Selecting this option will open the Update Notes dialog with two note types:

l Public Note
l Non-Public Note

Both note types have the following options:
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o Replace - replaces the existing note.
o Prepend - inserts the new note and a blank line before the existing note.
o Append - inserts a blank line and the new note after the existing note.

If Replace is selected and text is not entered in the note field, the existing note will be
deleted.

Notes longer than 255 characters will be truncated to 255.

If prepending or appending causes a note to be larger than 255 characters, you will see
the following message:

l Yes - updates the note(s).
l No - returns you to the Purchase order updating only the line items where the data
would not be truncated. The above message will appear for each line item that
may be truncated.

l Cancel - returns the user to the purchase order with the line item(s) still highlighted.
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New Index to Increase Workslip Speed

A new index was added to speed up the printing of PO line item work slips.
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Automatically Populate Authority Heading in Find Tool Dur-
ing Check Headings - Staff Client

A new administration setting lets you enable or disable the automatic population of the
heading in the Authority Records - Heading Find Tool when checking for duplicate
headings.

Open Administration Explorer > Profiles > Cataloging:

The default value for this setting is No.

It is available at the System, Library, Branch, Work Station, and Staff Member levels.

If this setting is enabled, the Find Tool is automatically populated when:

1. The user is working in a bibliographic record with an unlinked heading.
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2. A heading check is triggered either by saving the record as final or by selecting
Check Headings from Tools in the record workform:

3. The Check Headings Assistant Dialog Box displays the headings with no matching
authority record, and the user selects Details for one of the headings:
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4. The Check Headings Details Dialog Box opens, and the user selects Find to search
for a matching heading:

5. The Authority Records - Heading Find Tool appears with the For option pre-
populated using the heading subfield a.:

Note:
The user can change the search criteria before executing the search in the
Find Tool and search terms do not persist between searches.
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Retain Bibliographic Control Number During Over-
lay/Replace

Duplicate detection now maintains the control number of the existing bibliographic
record by default during the import overlay/replace process. Import permissions remain
unchanged.

When you choose Save incoming record as final; replace database record, the existing
record is overlayed by the new incoming record but its control number is retained.

When you choose Save record with highest encoding level. If encoding levels match:,
the Save incoming record as final; replace database record option is selected by
default. You can also choose to reject the incoming record or save the incoming record
as provisional. The control number is retained only when saving the record as final.
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Interactive Save of a Brand New Record

When creating a new bibliographic record, or importing and saving a new bibliographic
record using z39.50, the control number of the existing record will automatically be
retained when there is only one duplicate. You can choose which control number to
retain when there are multiple duplicates available.

A new column called Maintain control number has been added to the Duplicate
Detection dialog.
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If only one duplicate is found, the check box is checked by default and cannot be
unchecked. the control number of the suspected duplicate will be the one retained. The
record owner is also retained. This requires the Bib record modify permission
(overridable), and will update the modification date of the existing record.

If more than one suspected duplicate record is found, the user will have the option to
select which records to replace, and of those records, which control number will be
retained.
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Records in a status of provisional are not eligible for this feature, and will have a
disabled check box.
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Saving Default Remote Databases for Bibliographic
Record Searches

You can now save default remote databases that Polaris searches when you use the
Find Tool to search for bibliographic records.

Note: Default search databases are associated with your user account.

To save default search databases:

1. Open the Find Tool for bibliographic records and navigate to the Databases tab.
2. Select the remote databases you would like to search.
3. Select Options > Save as User Default.

Polaris saves your preferred remote search databases. When you open the Find
Tool for bibliographic records in the future, your preferred search databases are
already selected.

To clear saved default search databases:

1. Open the Find Tool for bibliographic records, and navigate to the Databases tab.
2. Select Options > Revert to System Default.

If an administrator deletes a remote database that is being used as a default search
database by one or more users, the database is automatically removed from each user's
saved default search databases.
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Save Item Record Bulk Changes as Templates

You now have the option to save item record bulk change settings as templates to reuse
your item bulk change criteria. This feature is available in the Staff Client and Leap.

The following new permissions must be assigned to enable this feature. They can be
assigned at the Permission Group, Workstation, and Staff member levels.

At the branch level, Item Bulk Changes Templates:

l Access – allows users to view and use the saved criteria.
l Create – allows users to create new saved bulk change templates.
l Modify– allows users to modify existing saved bulk change templates.
l Delete – allows users to delete saved bulk change criteria.

The following new permission is necessary if the library wants to allow staff to 'own'
item record bulk change templates. If the library wants all templates to be owned at the
sys/lib/branch levels, then they would not assign this permission to staff.

At the system level: Use 'own' item bulk change templates > Allow.
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The Staff Client Item Bulk Change dialog is updated to include these options:

l Template – select an existing item record bulk change template available to you.
l Save –modify an existing template.
l Save As – save item bulk change criteria as a new template.
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l Delete – delete an existing template.

The Leap Item Bulk change workform is updated to include these options:

l SAVE AS TEMPLATE - save item bulk change criteria as a new template.
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l Template - select an existing item record bulk change template from a list of tem-
plates available to you.

Leap also has a new Item Bulk Change Template workform to modify, copy, and delete
item bulk change templates.
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Undelete Record Sets

Sometimes a record set is deleted by accident, and this can be a difficult situation to
rectify if the user who deleted the set was not the creator.

You can now undelete record sets if this feature has been enabled by the system
administrator. Record sets now have a status of Final or Deleted. If the status of the
record set is Deleted, then staff could use the Undelete action similar to the item record
delete/undelete function.

This functionality can be accomplished in both Leap and the Staff Client.

The following sections provide more information about enabling, configuring, and using
the Undelete Record Set function:

System Administration

l System Administration Options to Retain Deleted Record Sets

l Delete Record Sets Permissions Updated

l Record Set Status
l Record Set Undelete Transactions

Staff Client

l Record Set Status in Record Set Header and Properties
l Undelete Menu Option and Icon for Record Sets
l Find Tool Updated for Deleted Record Sets
l Record Set Status in Find Tool Search Results

Leap

l Record Set Status in Record Set Header and Info Properties in Leap
l Undelete Menu Option for Record Sets in Leap
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l Find Tool Updated for Deleted Record Sets in Leap
l Record Set Status in Find Tool Search Results

System Administration Options to Retain Deleted Record Sets

Deleted record sets must be retained to enable the Undelete Record Sets option. These
are system level settings.

To retain Patron record sets, go to Administration Explorer > Profiles > Patron Services
> Retain deleted patron record sets. Select Yes.

To retain Cataloging record sets, go to Administration Explorer > Profiles > Cataloging >
Retain deleted cataloging record sets. Select Yes.
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Delete Record Sets Permissions Updated

Cataloging and patron record sets permissions are updated to support the ability to
permission the undelete of record sets that have been marked for deletion.
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l Cataloging Record Sets: Delete permission now includes /Undelete

l Patron Record Sets: Delete permission now includes /Undelete

Record Set Status

To support the ability to undelete a record set, record sets now have a status that is
stored as an additional column in the Record Sets table.

Record sets have a status of 1 = Final or 4 = Deleted.

Record Set Undelete Transactions

To support the ability to track deleted or undeleted record sets, two new types of
transactions are now available in the Transaction Logging database table:
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l Record set marked for deletion
l Record set undeleted

The following subtype data are included:

l 50 Type of Record
l 168 Record set RecordID
l 192 Record set owner
l 193 Record set name

Record Set Status in Record Set Header and Properties in Staff Client

Record set status is now in the Record Set Header on Record Set Workforms for
Authority, Bibliographic, Item, and Patron record sets. Record sets can have a status of
Final or Deleted.



What's New in Polaris and Leap

© 2019 Innovative Interfaces, Inc.
Page 36

Record set status is also now in Record Set Properties.
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Undelete Menu Option and Icon for Record Sets

An Undelete menu option and icon are now available for all four record set types: Patron,
Item, Bibliographic, and Authority.

The Undelete Menu option is on the File menu directly below the Delete option. The
keyboard control for this option is Ctrl+ U.
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The Undelete icon is to the right of the Delete icon on the Record Set Workform.

The Undelete option is only enabled if the record set's status is Deleted.

Find Tool Updated for Deleted Record Sets

The Find Tool in the Staff Client has been updated so that deleted record sets are
excluded from search results unless you search by Record Status or Record Set ID.

Record Status has been added to both the Cataloging Record Sets and the Patron
Services Record Sets Find Tools as access points for searches by Record Status:
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The following access points in the Find Tool have been updated to exclude record sets
with the status of Deleted from these search results:

l Creation Date
l Name
l Owner

Record Set Status in Find Tool Search Results

Record set status is now available in data returned in the Find Tool search results.
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Record Set Status in Record Set Header and Info Properties in Leap

Record set status is now in the Record Set Header on Record Set Workforms for
Authority, Bibliographic, Item, and Patron record sets. Record sets can have a status of
Final or Deleted.

Record set status is also now in Record Set Properties.
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Undelete Menu Option for Record Sets in Leap

An Undelete menu option is now in the header level ACTIONS button on all four record
set types: Patron, Item, Bibliographic, and Authority.

The Undelete option is only enabled if the record set's status is Deleted.
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Find Tool Updated for Deleted Record Sets in Leap

The Find Tool in Leap has been updated so that deleted record sets are excluded from
search results unless you search by Record Status or Record Set ID.

Record Status has been added to the Find Tool as an access point for searches by
Record Status:

The following access points in the Find Tool have been updated to exclude record sets
with the status of Deleted from these search results:

l Creation Date
l Name
l Owner
l Type
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Record Set Status in Find Tool Search Results in Leap

Record set status is now available in data returned in the Find Tool search results in
Leap.

A column called Record Status is now listed under Column Settings in the Find Tool. This
column is unselected by default.

Once selected, the column can be pinned and manipulated like all the other columns
under Column Settings.
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Call Number and Volume on Hold and Almost Overdue
Notices

The item call number and volume are now included on Hold Notices and Almost Overdue
Reminders.

Both are added to each of the following notices after the Format column:

l Holds - Full-page mailer
l Holds - Half-page mailer
l Holds - Half-page mailer - dot matrix
l Holds - Z-fold mailer
l Holds - Z-fold oversize
l Email - Almost Overdue
l Email - Almost Overdue Other Items
l Email - Reminder Almost Overdue
l Email - Request
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Circ Stats Added to Item View

The (YTD) circulation (circ) count and lifetime circ count stats are now displayed in the
Item Level view in the Bibliographic Records Preview window.

To view these stats:

1. From the Bibliographic Records Find Tool, right-click on a bibliographic record, and
select Preview.

2. The Preview window opens. The (YTD) circulation (circ) count and lifetime circ
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count stats are displayed in the Item Level view.
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New Total Holds Thresholds Include Inactive Setting

In previous versions of Polaris, inactive hold requests counted toward a patron's total
number of allowed hold requests. As of Polaris version 6.2, a new system-level Total
holds thresholds include Inactive setting lets you specify whether inactive hold requests
count toward a patron's total holds limit.

The new system-level Total holds thresholds include Inactive setting is now available on
the Terms tab of the Hold options window. This window is accessible in the
Administration Explorer by selecting Parameters > Request.

When the Total holds thresholds include Inactive check box is:

l Selected - Inactive hold requests count toward a patron's total holds limit. This is
the default setting.

l Not selected - Inactive hold requests do not count toward a patron's total holds
limit.
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New Patron Gender Options

New patron gender options now allow flexibility in how you track or don't track gender.

Gender Drop Down Menus

Patron registration workforms in the Staff Client, Leap, PowerPAC, and MobilePAC now
include Gender selection drop down menus.

All drop down menus start with a (None) option followed by a list of genders specified
for the specific organization. The (None) option is selected by default unless a patron
has already selected a gender. Selecting (None) sets the patron's gender to "null" in the
database as if they have opted out of a gender selection.
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Manage Genders

A Genders Database table is available at the system, library, and branch levels. Changes
to the table modifies it for all users. Select Database Tables > Genders.
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Entries can be added/modified/deleted.

l Amessage is presented for changes that affect all libraries.

l Database integrity is enforced on the deletion, not allowing a user to delete a row
that is in use by a patron with the following message presented.
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Editing the Genders Table requires a new permission. Select Security > System
Administration >Modify genders table: Allow. This permission is granted at the Staff
Member, Workstation, and Permission Group levels. It is not granted by default.

You can also manage gender displays. These can be managed at the system, library,
and branch levels. Select Parameters > Patron Services > Patron Registration Filter
genders.
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You can select the gender options to display and change the order in which they are
displayed.
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Gender Suppression

You now have the ability to suppress the Gender question when registering and opening
patron records. When suppressed, the Gender question will not be visible on patron
workforms, and gender is not tracked. Suppression is based on the patron's registered
branch.

To suppress Gender tracking in the Staff Client and Leap, select Branch > Parameters >
Patron Services > Patron registration options.

Select Display Options. When Gender is checked, it is suppressed.
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To suppress Gender in Self-registration, select Branch > Profiles > PAC > Patron access
options.

Select Self-registration. Gender is suppressed when Suppress gender selection is
checked.
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Gender No Longer Copied During Copy Patron Operation

Copying a patron record will not copy over the gender but should use the same
suppression rules unless/until the patron's registered branch changes.

Important Notes About Staff Client Offline Registration and Automated Offline
Upload

l While uploading offline transactions, specifically offline patron registration, using
Bookmobile or Automated Offline, the upload process will try to convert the exist-
ing single character gender (N, F, M) to the new GenderID values.
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l The new GenderID mappings are allowed to be deleted, but if the library plans to do
so, then they MUST keep them until ALL offline transaction files created on
releases older than 6.3 are uploaded.

l Once the library starts doing offline circulation on a 6.3 or newer staff client, they
can remove the default gender entries if they choose to do so, but they will not be
able to maintain a gender when uploading transactions from a previous release.

Important Notes about INN-Reach

The gender in the virtual patron record is set from the gender in the institutional patron
template. If the registered branch of the virtual patron is not set to display the gender in
the template, the gender of the virtual patron will be set to (None). The INN-Reach gender
applied to the institutional patron template should be a gender that is available at all
branches.

Important Notes about SimplyReports

Any saved reports that used the Gender field will now be broken. To fix these:

1. Open the report for editing.
2. Verify your Gender selection is still valid.
3. Save the report.
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Suspend and Resume Outgoing Circulation API Messages
for INN-Reach

Suspend and Resume buttons were added to the Current Queue Status section of the
Status and Statistics page in Polaris INN-Reach Administration. These buttons provide
the ability to suspend and resume outgoing circulation API messages. You must have
the INN-Reach Modify user permission to use this feature. Otherwise, the Action column
and the buttons do not appear.

When you select the Suspend button, the Resume button appears.
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Additional Item Columns Added to Request Manager

You can now view Item Agency and Item Location information directly in the Request
Manager. This ability is available in both the Staff Client and Leap. This information was
previously only visible by opening each request and viewing the Notes field. The function
of the Notes field remains unchanged; information will still display in the Notes field.

Customers must be licensed for INN-Reach in order to view the new columns. Customers
who don’t use INN-Reach will not see the additional columns.

Staff Client View

Leap View
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Support for JetPay E-commerce in Polaris PowerPAC

You can now use the JetPay gateway to accept credit card payments from Polaris
PowerPAC. JetPay is a hosted method of accepting credit card payments from
PowerPAC. You can enable the use of JetPay at the system, library, or branch level.

When you use JetPay for payments, JetPay handles much of the responsibility of
Payment Card Industry Data Security Standard (PCI DSS) compliance for your library. No
credit card information is stored in the Polaris database when a payment is made via
JetPay.

Note:
The use of JetPay for payments from the staff client, Polaris
ExpressCheck, or Mobile PAC is not supported.

To enable JetPay e-commerce, you must:

1. Set up a JetPay account
2. Set up JetPay processing in the Administration Explorer

Set Up a JetPay Account

To enable the use of JetPay for accepting credit card payments from Polaris PowerPAC,
contact JetPay to establish an account for your library.

When establishing your library's JetPay account, make a note of the following two
pieces of information:

l Client key
l Web key

You will need this information to set up JetPay processing in the Administration
Explorer.

Set Up JetPay Processing in the Administration Explorer

To configure Polaris to use JetPay for processing credit card payments from PowerPAC:

https://www.jetpay.com/
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1. In the Administration Explorer tree view, navigate to the organization for which you
want to enable JetPay processing, and click Parameters > Credit Card Payment.

2. Double-click Online Payments: Configure.

The Online Payments Settings dialog box opens.

3. In the Payment processing gateway list, select JetPay.
4. Click Properties.

The JetPay dialog box appears.
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5. Enter the following connection information:
a. Transaction URL - Enter the following URL: 

https://magic.collectorsolutions.com/magic-api/api/transaction/redirect

b. Payment page URL - Enter the following URL: 

https://magic.collectorsolutions.com/magic-ui/PaymentRedirect

c. Transaction fee URL - Enter the following URL: 

https://magic.collectorsolutions.com/magic-api/api/fee

d. Client key - Enter the client key provided when your library set up a JetPay
account.

e. Web key - Enter the web key provided when your library set up a JetPay
account.

f. Post-back URL - Enter the post-back URL for your site, using the format
below:
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https://<www.mylibrary.org/polaris>/payments/PostbackJetPay.aspx

Note:
Replace <www.mylibrary.org/polaris> with your Polaris
PowerPAC URL.

This field accepts a maximum of 250 alphanumeric characters.

g. PAC return URL - Enter the URL that will be displayed when the user clicks the
return link on the JetPay final payment transaction page. To use your lib-
rary's PowerPAC patron account Fine & Fees page, use the format below:

https://<www.mylibrary.org>/polaris/patronaccount/finesfees.aspx

Note:
Replace <www.mylibrary.org/polaris> with your Polaris
PowerPAC URL.

This field accepts a maximum of 250 alphanumeric characters.

h. Donations PAC return URL - If you plan to accept donations, enter the URL of
the Polaris PowerPAC page that will be displayed when the user clicks the
return link on the JetPay final payment transaction page. This field is
required. If you do not plan to accept donations, simply enter your PAC
Return URL. This field accepts a maximum of 250 alphanumeric characters.

i. Library absorbs fees - Select this check box if you want the library to absorb
the JetPay credit card processing fee. This check box is a shadow setting of
how your account is set up in JetPay to display warnings and fees to the pat-
ron and it must match the corresponding setting in JetPay. If this check box
is not selected, the processing fee is billed to the patron.

j. Click OK.
6. Configure the following settings on the PowerPAC tab of the Online Payments Set-

tings dialog box:
a. Allow online payments - Select this check box to enable the use of JetPay for

credit card payment processing.

Note:
In PowerPAC, patrons pay fines on the Fines and Fees page of
the patron account. Be sure the PowerPAC profile Navigation:
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Fines & fees is set to Yes for the organization to allow patrons
to access this page. For more information, see Enable patron
account access - PowerPAC.

b. Minimum fine - Enter the minimum fine amount that will be accepted via
credit card payment. The default value for this setting is $1.00.

Note:
If the amount a patron owes is less than theMinimum fine
value, the Pay fines link does not appear in the patron's
account in Polaris PowerPAC.

c. Processing fee -This is controlled completely by JetPay and should be set up
there. To charge a processing fee for fine payments, enter an amount in the
Processing fee box. The maximum value for this setting is $20.00. The
default value is $0.00.

d. Display privacy policy - To display a privacy policy link in Polaris PowerPAC,
select Display privacy policy. For more information, see Privacy and Refund
Policy Display Options.

e. Display refund policy - To display a refund policy link in Polaris PowerPAC,
select Display refund policy. For more information, see Privacy and Refund
Policy Display Options.

f. Allow donations - Select this check box to enable the use of credit card pay-
ments for donations.

g. Processing fee - This is controlled completely by JetPay and should be set up
there. To charge a processing fee for donations, enter an amount in the Pro-
cessing fee box for donation payments. The maximum value is $20.00. The
default value is $0.00.

h. Allow patron to designate title purchase - Select this check box to allow the
donor to direct a donation toward a title purchase in a specific subject area.
When this option is selected, the donations page includes a field where the
donor can specify a title purchase.

7. Click OK to save your settings.
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Display Improvements in Polaris PowerPAC

Item availability information in the PowerPAC user interface has been improved to
reduce horizontal scrolling. This change makes it easier for users to navigate Polaris
PowerPAC using mobile devices.

Tablets will display item availability information in a table format similar to that on a
PC.

Phones will display item availability information in a list.
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Multilingual Support for Dashboard Titles

If your library is licensed for additional languages in the PAC, you can now view
dashboard labels in a language other than English, and the labels can be customized.
Previously, when a different language was selected, the dashboard labels would
continue to display in English. Labels can now appear in the language the user selects if
the database contains the appropriate translation.

Two dashboard types can be configured: Polaris PowerPAC dashboards and customer-
defined dashboards. The following sections describe how to customize each dashboard.

Customize the Polaris PowerPAC dashboard

Each of the Polaris-defined dashboards now have a system-assigned mnemonic that
can be used to edit the dashboard’s default title. You can view a dashboard’s mnemonic
in the properties box that opens when the dashboard label is double clicked.
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To change a mnemonic, edit the strings associated with that mnemonic in WebAdmin.
The following table lists new mnemonics and associated values that can be used with
multilingual support.

Mnemonic Value
PACML_DASH_CHILDFICTIONSERIES Children's Fiction Series

PACML_DASH_CHILDILLUSTRATED Children's Illustrated

PACML_DASH_DONATION Make a Donation

PACML_DASH_EARLYMIDDLE Early and Middle Grade Readers

PACML_DASH_HARDFICTION Hardcover Fiction

PACML_DASH_MASSMARKET Mass Market

PACML_DASH_MOSTCIRCAUTHORS Most Circ'd Authors

PACML_DASH_MOSTCIRCSUBJECTS Most Circ'd Subjects

PACML_DASH_MOSTCIRCTITLES Most Circ'd Titles

PACML_DASH_NEWTITLES New Titles

PACML_DASH_ONORDERITEMS On-Order Items

PACML_DASH_PAPERFICTION Trade Paperback Fiction

PACML_DASH_PAPERNONFICTION Trade Paperback Non-Fiction

PACML_DASH_YOUNGADULT Young Adult

Some dashboards are not listed. They already have mnemonics that allow them to be
customized in WebAdmin. These dashboards are listed in the table below.

Mnemonic Value
PACML_HEADER_1007 Patron Account

PACML_FEATURE_DASHHEAD Feature It!

PACML_DASHBOARD_XSL_1551 Title Lists

PACPROF_NARROW_DASH_LABEL (multilingual SA
string) Narrow Search

PACPROF_RELATED_DASH_LABEL (multilingual SA
string) Related Searches

ACPROF_NARROW_DASH_LABEL (multilingual SA string) Narrow Community
Search
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PACPROF_RELATED_DASH_LABEL (multilingual SA
string)

Related Community
Search

PACML_DASHBOARD_XSL_1558 Saved Searches

PACML_RVT_DASHHEAD Previous Titles

Customize a customer-defined dashboard

You can now associate a multilingual mnemonic with user-defined dashboard labels.

When creating a new user-defined dashboard, specify a mnemonic along with a default
title. Mnemonics should not contain spaces.

l Mnemonics are optional. If multiple languages are not used in PowerPAC, a mne-
monic does not need to be specified during dashboard creation. The dashboard
title will only display what is entered in the dialog box “Title” field.
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l Amnemonic is only specified when creating a dashboard. To add a mnemonic to
an existing user-defined dashboard, the old dashboard must be deleted and a new
one created. When the new dashboard is created, a mnemonic can be specified.

Strings for each language are created automatically with the title specified as the default
display value for the mnemonic. The title label can then be edited for each language
using the mnemonic in WebAdmin.
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Configure the Maximum Length of the Title Summary in
PowerPAC Search Results

The new PowerPAC profile Title Display: Number of characters in the Summary (Short)
allows you to specify the maximum number of characters of the Summary (Short) field
that are displayed in the brief and full search results views for a title in the Polaris
PowerPAC.

By default, this profile is set to "0", and the number of characters displayed is not limited.
You can enter a value between 0 and 4000.

When Summary field text exceeds the specified limit, Polaris PowerPAC displays
truncated summary text followed by a More link. Users can clickMore to expand the
display to show the entire summary, and click Less to collapse the display again.
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Compile CSS File with Polaris Web Admin Tool

An option to compile custom CSS for custom themes has been added to the Polaris Web
Admin tool for hosted libraries without direct access to the PowerPAC server.

The new option is found under PAC Tools > Compile CSS:

When a site has at least one custom theme, a table similar to the PAC reload is
displayed:

The table contains:

l PowerPAC Server - the names of the servers on which the custom themes are com-
piled.

l Custom Theme - the name of each custom theme found on the server. The name
is clickable and executes the compile/recompile action on click.

l Status - the status of the compile. This column will display one of the following:
o Last date/time the theme was compiled successfully
o Theme not yet compiled
o Compiling
o Compile failed with any error details
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o Compile successful

When the site does not have custom themes, the page will display the following
message:
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Security Improvements for Patron Password Workflows

Polaris 6.3 contains updates that improve security for patrons who create or reset the
password for their library account from Polaris PowerPAC, Mobile PAC, or ExpressCheck.

In previous versions, a patron could request a new password by clicking a Forgot your
password? link in either Polaris PowerPAC, Mobile PAC, or ExpressCheck. The library
would then send a new password to the patron in an email message.

If a patron had a library account but had never created a password for the account, the
patron could create a password by clicking a Create a password link in Polaris
PowerPAC, Mobile PAC, or ExpressCheck.

In Polaris 6.3, a patron who wishes to create or reset a password can click a link in
Polaris PowerPAC, Mobile PAC, or ExpressCheck and receive an email containing a time-
sensitive link to a Reset Password page where the patron can configure a new password.
Libraries can use the new Reset password link timeout duration setting to specify the
time period during which the time-sensitive password reset link remains valid.

Patron Workflow for Creating or Resetting a Password

Configuring the Reset Password Link Timeout Period

Other User Interface Changes

Patron Workflow for Creating or Resetting a Password

Patrons can use the workflow described below to reset a library account password or
create a password for the first time in Polaris PowerPAC or Mobile PAC.

To reset or create a password:

1. In Polaris PowerPAC, select Log In at the top of the page or Log In/Register from
the My Account menu. In Mobile PAC, click theMy Account link. Or, in
ExpressCheck, scan your barcode or select Forgot your library card? Press here!.

The Log In page appears.

2. Click the Forgot your password? link.

A Reset Password page appears.

3. Enter your user name or barcode in the Username or Barcode box.
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4. Click Submit.

Your library sends an email to the email address associated with your library
account.

5. Open the email and click the provided reset password link.

A Reset Password page opens in a new browser window or tab.

6. Enter your new password in the New Password box.
7. Enter your new password in the Confirm Password box.
8. Click Submit.

A confirmation message appears, and your library account is updated with your
new password.

Configuring the Reset Password Link Timeout Period

A new Reset password link timeout duration profile setting is now available on the
Profiles > PAC tab of the Administration Explorer.

This setting determines the time period (in minutes) during which the reset password link
emailed to the patron remains active. The setting is available at the System, Library, and
Branch levels. You can enter a value between 1 and 999 minutes. By default, the timeout
period is set to 60 minutes.

If a patron clicks the reset password link after the active period has elapsed, a Reset
Password page appears. The page notifies the patron that the reset password link has
expired and prompts the patron to request a new one by entering a library user name or
barcode.

The nightly Patron Processing SQL job removes reset password links after the specified
active period has elapsed.

Other User Interface Changes

In the Administration Explorer, the Display prompt for new password setting no longer
appears on the Log In tab of the Patron Access Options profile. This profile setting is no
longer needed; a patron with an existing library account who has never created a
password can create one using the workflow described above.
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Updated E-mail Forgotten Password Label

The label for the optional system email forgotten password feature has been updated.
The label is now called E-mail reset password link.

To access the feature in the Administration Explorer, go to Profiles > PAC > Patron
Access Options > Login:
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Leap Offline

Permission based Leap Offline is now available for circulating materials while your
database server or network are unavailable. Each Windows user will have a unique
installation of Leap Offline for each browser they use. Installation of the application is
initiated through Leap and should be bookmarked for future use. The application uses
the local storage features of your browser to store limited installation data that is
required to process offline transactions. No patron data will be stored locally.

The Leap Offline application is shown below:

Offline transactions are stored in the local storage of the user's browser until the user
chooses to send them to the server for processing or to delete them.

As you work in Leap offline, you will see your transaction count increment with each
check out. The Transactions badge will keep you informed of your progress.

Selecting the Transactions badge will open a dialog showing all the offline transaction
files you have generated, with an option to delete them. You should only delete
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transaction files you created while training or testing. Deleting files cannot be undone.

New Permission for Leap Offline Setup

A system administration permission to control which users can complete the Leap
Offline installation is now available. Select Security > Leap > Setup Offline > Allow.
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l This permission is not assigned at upgrade.
l Workstation access is permitted by default.
l The permission is not overridable.

Web Browser Information for Leap Offline

The following browsers are compatible with Leap Offline:

l Windows Chrome v74.0.3729.157+
l Windows Edge v44.17763.1.0+
l Windows Firefox v66.0.5+
l OS X Safari v12+
l OS X Chrome v74+
l iOS Safari 11.3+ (eg: iPad 5th+, iPad Air+)

Incompatible browsers:

l Windows Internet Explorer (all)
l iOS Safari 1.0-11.2
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Leap Offline Installation

You must have the Leap Offline permission enabled and use a compatible web browser
to install the application.

1. If Leap Offline has not been previously installed, you will see an installation Warn-
ing icon. To install, select theWarning icon:

2. Select Install Offline:

3. You will see the following message:
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4. Select Leap Offline.

5. Leap Offline will open in the browser.

Note:
The URL used to access Offline is case sensitive, and you should create a
bookmark for it to access the Leap Offline application for future sessions.

Note:
Offline data (both setup data AND actual transaction data) is stored in the
local storage of the user's browser. You should not clear your cache while
you have unprocessed offline transactions.

Refresh Leap Offline Installation

You have an option to update your Leap Offline installation with any changes made to
system administration without manually clearing your cache and re-installing the
application.
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This option is found in the Leap application. Select User Profile > Refresh Offline
Installation.

Refreshing the installation updates the following values:

l User ID
l User Name
l Workstation ID
l Workstation Branch ID
l Workstation Name
l Branch ID
l Standard Loan Period
l Branch Name
l Branch Phone
l Branch Home Page
l Branch Receipt Note
l Locale Name

Leap Offline Settings

The Settings workform in Leap Offline has several options.
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Select Print Options to enable Check Out receipt printing for patrons. This selection is
persistent unless the cache is cleared.

Select Special Loan to set a special loan period that applies to all checkouts. If selected,
this value is stored globally for the loan session.

SelectWorkform Defaults to view the value that is used to calculate the due date if the
user doesn't choose to use the special loan. This value is not editable.
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Select Settings > Installation to view installation settings. All values stored in the web
browser's local storage during Leap Offline installation are displayed.

Uploading Offline Transactions

If you have unprocessed offline transactions when you log into Leap, you will see the
following message:

The User profile icon is also set to theWarning icon. Select the icon to access options to
process the offline transactions.

l The Send Offline Files to Server option sends all unprocessed offline transactions
to the server for processing. All transactions sent to the server will be processed
and uploaded using the Automatic Offline Upload process.

l The Delete My Offline Files options deletes all unprocessed offline transactions
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from the browser. The deleted transactions cannot be recovered.
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Columns Added For Display in Leap Item Find Tool

The following configurable columns were added under Column Settings in the Leap Item
Find tool:

l Author
l Due date
l Publication date
l YTD Circ
l Prev YTD Circ
l Lifetime Circ
l YTD in-house use
l Prev YTD in-house use
l Lifetime in-house use
l Public notes
l Non-public notes
l Physical condition
l Copy number
l Assigned branch abbreviation
l PO number

In the Item Find tool select Column Settings:

The added columns can be selected and configured for display in the Item Find tool.
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Improvement to Patron Properties in Leap

The patron's birth date is now included in the list of patron information that appears
when you view patron properties in Leap.
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Improved Sorting for Title Lists in Leap Patron Views

Lists of titles that appear in patron views in Leap are now sorted using Name Authority
Cooperative Program (NACO ) normalization rules.
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Editing Saved Reports in SimplyReports

You can now edit all column and filter settings for the following types of saved reports:
fund list reports, invoice list reports, and purchase order list reports.

You can also edit many other types of saved reports. See the SimplyReports user
documentation for more information.
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