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1: SUMMARY 

QGIS is an open source GIS program for the display and analysis of GIS data. It  has developed 

significantly in the past few years and is now a valuable tool for the mineral exploration industry , 

and a viable alternative to the commercially available GIS packages. Although not specifically 

written for geological applications, QGIS can do most of the required GIS tasks required by today’s 

geoscientists. The terminology is different to the usual earth sciences programs but many QGIS 

algorithms do the same thing but with a different name. There is no dedicated drill hole or cross 

section module available for QGIS currently, but discussions and plans are progressing to develop 

this module in the future. The Geoscience plugin is a basic drill hole display option. 

This manual examines QGIS and how QGIS can assist geoscientists to undertake mapping and 

geoscientific tasks in their day-to-day work. The manual has evolved during several years teaching 

QGIS to geoscientists in Western Australia and has been produced to offer a go-to document for 

earth science related GIS activities. 

Accessing data from the internet via web map and web feature servers is il lustrated to show how 

using this data can help with compiling available data for an area. Detailed aerial photography and 

Google Earth can be easily integrated with mapping data to allow the creation of accurate base 

maps for a variety of geological applications. A wide range of vector and raster (grid and image) 

data formats can be easily imported into QGIS, including GPS gpx files.  

The presentation options for point, line and polygon data are extensive and easily customised. A 

variety of geological symbols and pattern fills can be applied to points, lines and polygons. 

Geochemical and geophysical data can also be presented in a variety of display options. Basic 

3D display of map data is also available via the QGIS2threejs plug-in. 

QGIS has many plug-ins for specialised tasks and the semi-automatic classification plug-in (SCP), 

is one example where users can select, download and process ASTER, Landsat and Sentinel 2 

satellite data. It is recommended that new users peruse the plugins list to see what plugins are 

available and for those that may be of use in their work. 

Map production is easy in QGIS with the “Print Layout” allowing extensive options for the display 

and printing of maps. 

This document is a working draft and in continuous development. There may be errors and 

omissions, and these will be rectified as time permits. This manual applies to version 3.6. Please 

feel free to share this document. 

 

2: INTRODUCTION 

This document is aimed at the exploration geologist in Western Australia, but the techniques 

outlined are easily transferrable to other areas. The author has been using QGIS since 2015 and 

the version used in this document is version 3.6. 

The reader is encouraged to join the international online QGIS user forum at 

http://lists.osgeo.org/mailman/listinfo/qgis-user and the Western Australian QGIS user group 

(contact the author for details).  

This document will not go into the detail that is covered by the QGIS User Guide and Training 

Manuals (https://docs.qgis.org/testing/pdf/en/) and other reference books (e.g. Graser 2016) on 

QGIS on topics like editing etc., but will discuss those tools used particularly in geological 

mapping, mineral exploration and remote sensing. See this video for an explanation of some of 

the advanced editing functions - https://youtu.be/jZYKGrIyVCA.  

http://lists.osgeo.org/mailman/listinfo/qgis-user
https://docs.qgis.org/testing/pdf/en/
https://youtu.be/jZYKGrIyVCA
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The original default file format for QGIS was the ESRI shape file (*.shp) and this format has been 

around for many years and can be read by many software products. It is however, an old format 

and has limitations, e.g. field names are limited to 10 characters. QGIS is adopting the new 

“Geopackage” file format as its default spatial file format. Geopackage files can have different 

types of vector geometry – points, lines and polygons – and can also include raster images. 

Geopackage files can be up to 140 TB in size! Layers can be imported into an existing 

Geopackage by dragging from the Layer panel onto the Geopackage in the Browser panel. Styling 

information can be saved into the Geopackage file. When digitising into a Geopackage file, each 

new feature is auto numbered. Raster images imported into a Geopackage appear to be 

significantly compressed without any major loss of quality. ESRI products can read Geopackage 

files. 

The author has been using QGIS since 2015 after about 20 years using the MapInfo -Discover 

software. He has been involved in exploration and mining geology for over 40 years, with almost 

20 years with CRA Exploration Pty Limited, Argyle Diamonds and Rio Tinto Exploration from 1979 

till 1997. The past 20 years (1998 – present) has been engaged in consulting roles to the diamond 

exploration and mining industry with activities in Australia, Brazil, China, Greenland and India, and 

exploration for other commodities including base metals, iron ore, and manganese.  

3: ABOUT QGIS 

QGIS is a user-friendly open source Geographic Information System (GIS) licensed under the 

GNU General Public License and is an official project of the Open Source Geospatial Foundation 

(OSGeo). It runs on Linux, Unix, Mac OSX, Windows and Android and supports numerous vector, 

raster, and database formats. 

QGIS is a volunteer driven project. They welcome contributions in the form of code contributions, 

bug fixes, bug reports, contributed documentation, advocacy and supporting other users on their 

mailing lists and gis.stackexchange.com. If you are interested in actively supporting the project, 

you can find more information under the development menu and on the QGIS Wiki.  If you find 

QGIS valuable in your work place, please donate to the QGIS project – the details are on the 

website. 

QGIS provides a continuously growing number of capabilities provided by core functions and 

plugins. You can visualize, manage, edit, analyse data, and compose printable  maps.  

This document will mainly deal with work flows for geoscientists but there are many other tools 

available in QGIS and worthy of some exploration of their functions. Currently QGIS does not have 

a detailed downhole or cross section display option, but there are groups across the world keen 

to crowd source the development of the drill hole plug-in. The Geoscience plugin does display drill 

holes in plan and in cross section but is limited in its features. QGIS does not also handle all the 

various geophysical processing options, and again there is interest from various groups to develop 

plug-ins for geophysical processing. 

A complete revision of QGIS has been undertaken with the release of version 3. Although the user 

interface is similar there has been an extensive re-write of the software behind the interface. 

A good explanation of QGIS and where it came from can be found here 

https://www.youtube.com/watch?v=As4hfPecxoU.  

If you find QGIS makes a valuable contribution to your business, please consider making a 

donation to assist with continual code improvements – see this link 

https://qgis.org/en/site/getinvolved/donations.html. 

https://www.youtube.com/watch?v=As4hfPecxoU
https://qgis.org/en/site/getinvolved/donations.html
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Installation options are available on QGIS download page 

(https://qgis.org/en/site/forusers/download.html) with options to download either the development 

version (via OS4Geo), the v3 standalone installer (recommended) or the v2 standalone installer 

(no longer being updated). Both 64 and 32 bit versions are available. 

QGIS has been using ESRI shapef iles as the default spatial file format but the new “GeoPackage” 

format is far superior and will probably become the default file format for QGIS in the near future. 

Shape files have a number of limitations such as field/attribute column names are limited to 10 

characters, it lacks a time data type, only supports text fields to 255 characters in length and is 

limited to 2 GB in size. 

GeoPackage files on the other hand allows point, line vector and raster files to be stored in the 

one file. Formats/styles can be saved into the Geopackage file and it can be up to 140 TB in size.  

When adding features during digitising, for example, a Geopackage file will automatically populate 

the id field with sequential numbers. See this web link for further information 

https://carto.com/blog/fgdb-gpkg/. 

 

4: INSTALLING QGIS 

 

4.1 PC Installation 

 

The QGIS program can be downloaded from the QGIS Project website http://www.qgis.org/en/site/ 

and a choice can be made between 32 and 64 bit versions of the recent release and long term 

release version (3.4). Note that the v2 options are no longer supported and users and encouraged 

to use v 3. The Standalone Installers will install the program into the Program Files directory.  

The OWGeo4W option can be also be used and places a small executable file on your PC which 

can be run when desired to update to the latest versions of the LTR and development versions. 

This version installs the software into the root directory of your PC (e.g. C: \OSGeo4W64). For 

first-time users, it is recommended to install the “Standalone” version.  

 

https://qgis.org/en/site/forusers/download.html
https://carto.com/blog/fgdb-gpkg/
http://www.qgis.org/en/site/
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The standalone installer will install the program into the program files folder and create a folder 

on your desktop with shortcuts to the run the program. I t is recommended to run the “QGIS 

Desktop x.x with GRASS 7.x.x” version which runs the GIS program and associated GRASS GIS 

functions.  

When you run the OSGeo4W option you see the following screen shot. For a first -time installation, 

choose the “Express Desktop Install” which will install the programs and required utility files.  
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After the initial “Desktop Install”, you can then check for updates by running the “osgeo4w-setup-

x86_64.exe” file again (usually located in the Downloads folder) where you can select “Advanced 

Install” and select which products you wish to update. The OSGeo4W option can be used instead 

of the Standalone Installer option. 
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User manual and training documents can be viewed, or pdf versions downloaded from the QGIS 

web site (https://qgis.org/en/docs/index.html). 

 

 

The desktop is similar to other GIS applications with menu items along the top and numerous 

buttons/icons to make it easier to select various options without having to navigate menus. All the 

menu items and panels are customisable to user preferences. QGIS has operations to import 

vector and raster data from a variety of formats into QGIS, with excellent editing and analysis tools 

from the integration of other GIS systems such as GRASS and SAGA. Some of these tools are 

illustrated in the right-hand panel of the figure above. 

If you need to reset the QGIS window and panel locations, go to Settings > Options > System tab, 

select the Reset button (right hand side of screen) and re-start QGIS. 

The appearance of the desktop can also be changed by using the Settings > Options > General 

tab and in the Application section find the UI Theme where the appearance of the desktop can be 

modified. A recent addition here is the “Blend of Grey” option.  

4.2 Mac Installation 

 

Installation on a Mac is different than for a PC and it is recommended at this time to use the link 

at Lutra Consulting (https://lutraconsulting.github.io/qgis-mac-packager/) to download and install 

QGIS. 

Install the LTR or the Latest Release version. 

https://qgis.org/en/docs/index.html
https://lutraconsulting.github.io/qgis-mac-packager/
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To install the custom (geological) SVG files on a Mac, in QGIS, go to Settings > Options > System 

tab and look for the location of the svg files – something like 

/Applications/QGIS3.app/Contents/MacOS/../Resources/svg/. Use the Finder to navigate to the 

Applications folder, then right click on the QGIS program icon, select “Show Package Contents”, 

open the “Contents” folder and the “Resources” folder. Put the custom (geological) SVG folders 

into the SVG folder. 
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5: PLUG-INS 

Plug-ins are small utility programs that greatly expand the capabilities of QGIS. There are currently 

over 450 plug-ins available for download. These plug-ins are all free and have usually been written 

to solve a specific problem or task for users. It is recommended that users peruse the plugins list 

to see what plugins might be applicable to their workflow.  

Eleven plug-ins are installed by default in version 3.6 as are listed below. 

Coordinate Capture 
DB Manager 
eVis 
Geometry Checker 
Georeferencer GDAL 
GPS Tools 
GRASS7 
MetaSearch Catalog Client 
Offline Editing 
Processing  
Topology Checker 
 

To use these pre-installed plug-ins, you may need to enable them in the Plug-Ins > Manage and 

Install Plug-Ins > Installed window. Enable the plug-ins by selecting the check box next to the 

plug-in. 

 

Additional plug-ins that are recommended are as follows; 

Calculate Geometry 
Data Plotly (graphing of data) 
Geoscience (experimental, for plotting drill holes on plans and sections) 
importPhotos (import photos with embedded GPS coordinates) 
MMQGIS (various selection and geocoding tools) 
POI Exporter (useful for uploading points to a GPS unit)  
QuickMapServices (add additional services under the extra services option) 
QFieldSync (synching project for use in QField and creating basemaps) 
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QGIS2Threejs (3D viewer) 
Semi-Automatic Classification (satellite data selection and processing)  
Shape Tools (creation of numerous types of vector objects) 
Spreadsheet Layers (used to import Excel spreadsheets) 
SRTM Downloader (for accessing SRTM elevation data)  
Virtual Raster Builder (alternative method to create RGB images) 
 

If the QGIS start-up is being significantly delayed during start-up (“Loading Plugins”) then they 

can be temporarily disabled (Plugins > Installed, tick off those not needed) and only turned on 

when needed. 

In the Plug-Ins > Settings page, check the “Check for updates on start-up” and “Show also 

experimental plugins”. This will then alert the user to updates of existing plug-ins and the release 

of new plug-ins whenever QGIS is started. Note that when you first open the Plugins manager, 

you may see a “New” tab to show you what new plugins have been released  since you last opened 

the Plugin Manager. If you are working off-line with no internet, turn-off the “check for updates on 

start-up” to skip the web search and update function.  

 

 

Some managed IT systems block the loading of the Plug-in’s repository data. If this happens, try 

selecting the Settings > Options > Network, and check the use proxy server. Try again to download 

the repository. If this loads the repositories, then uncheck this box and try again to install the 

plugins. 

Network managers may also restrict the installation of plugins. If you have problems, contact your 

network manager. 
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6: DATA MINING AND PUBLIC DATASETS 

Many government and private corporations have made available datasets for use in GIS programs. 

There may be usage restrictions and the conditions of use should be checked at the data source. 

The amount of free data on the web is truly amazing and users are encouraged to explore the web 

for data. 

QGIS has many options to access on-line web datasets. These can be in the form of a WFS (web 

feature service – vector data), WMS (web map service – raster data) or as a WMTS (web map tile 

server – tiled raster data, e.g. Google Earth). Australian data can be searched at “data.gov.au” 

and Western Australian data is available at “data.wa.gov.au”. 

Satellite data for the ASTER, Landsat, MODIS and Sentinel missions can be downloaded and 

processed via the Semi-Automatic Classification plug-in in QGIS or via the USGS EarthExplorer 

portal and this is discussed below. Remote sensing satellite data (including Hyperion multispectral 

scanner and radar data) can also be downloaded via the USGS EarthExplorer and ESA (European 

Space Agency) websites. 

6.1 Australian Data Sets 

 

The Australian government has the “National Map” portal (https://nationalmap.gov.au ) where data 

can be accessed for Australia-wide data sets or from the individual states and territories. The WA 

DMIRS (WA mines dept) data can also be accessed via this portal.  
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6.2 Geological Survey of Western Australia 

 

The Department of Mines, Industry Regulation and Safety (formerly the Department of Mines and 

Petroleum, http://www.dmp.wa.gov.au/) is home to the Geological Survey of Western Australia 

(GSWA). This site contains many data sets, most of which can be downloaded from the “Software 

and Data Centre” (https://dasc.dmp.wa.gov.au/dasc/). Raster and vector data can also be 

accessed live via their WMS and WFS services 

(http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Image_W

eb_Service_definition.pdf and 

http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map

_Service_definition.pdf). 

Registered raster files of the 100k and 250k geological map sheets have been mosaiced into 1:1 

million map sheet areas and are in jp2 (jpeg2000) format registered in GDA94 MGA grid 

coordinates. The “jp2” format contains the projection and registration data embedded in the file. 

Raster files of individual map sheets in either GDA94 lat/long or MGA can also be downloaded 

from the data centre. 

The digital vector files for the 250k and 100k geology sheets vary in their data content depending 

upon the age of the map sheet edition. The GSWA use ArcView for their GIS system and many of 

their datasets contain “lyr” style and GeoMap “gmp” files. It has been requested that the data 

supplied by the GSWA also contain the colour and pattern information to allow users of other GIS 

systems (like QGIS) to style their maps like the GSWA style. This is a work in progress. North 

Road Consulting are developing a plugin to convert “lyr” style files to QGIS style files and this will 

go a long way in allowing QGIS users to style their maps in a similar fashion to the Arc GSWA 

maps. 

6.3 Landgate and Open Data WA 

 

The WA government has made available a large variety of GIS datasets through their Open Data 

website (data.wa.gov.au). Data from other states can be accessed in a similar manner. Searches 

can be made on this site and both vector data and web service links are supplied. More detailed 

datasets are available for WA from Landgate, but they may require a subscription. Many datasets 

are however free, and registration is no longer required for the free datasets. 

Links to some of the WA web services are as follows; 

WMS Links 

Public: 
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning/MapServer/WMSServer  

Imagery: https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSServer 

WFS Links 

Maps 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning_WFS/ MapServer/WFSServer 

Imagery 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Imagery_and_Maps_WFS/MapServer/WF SServer 

 

http://www.dmp.wa.gov.au/
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Image_Web_Service_definition.pdf
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Image_Web_Service_definition.pdf
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning_WFS/MapServer/WFSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Imagery_and_Maps_WFS/MapServer/WFSServer
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Australian Bureau of Statistics: https://www2.landgate.wa.gov.au/ows/wfsabs_4283/wfs 

To add this WFS and WMS layers to QGIS, you use the Layer > Add Layer > Add WMS/WMTS 

Layer. 

 

 

An example of linking to the Landgate imagery is shown below.  
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Some services may require you to register for a username and password. 

Access to vector data is via the add WFS (web feature server) option. See below for the list of 

publicly available data (no sign in required) from the Landgate server.  
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6.4 Geoscience Australia 

 

Geoscience Australia (GA) provides an extensive array of national datasets (see this link for more 

information “data.gov.au/dataset”).  

Digital elevation data is also available across Australia from Geoscience Australia 

(http://www.ga.gov.au/elvis/) at a resolution of 1 arc second (approximately 30 m) and is available 

as a hydrologically conditioned and drainage enforced version (DEM-H). This is a 26 Gb zip file 

and can be downloaded and the author has cut this into UTM zones which are approximately 7 - 

8 Gb in size each zone to improve useability. Depending upon the speed of your PC/laptop, these 

may need to be further cut into 1:1 million map sheet areas. The 9 second DEM (approximately 

250 m) is about 0.8 Gb in size, is also available.  

http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
http://www.ga.gov.au/elvis/
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Geoscience Australia, 9 second DEM 

Many of these datasets are also available as web services – see this link 

http://services.ga.gov.au/. 

Geophysical data incorporating magnetics, gravity, radiometrics and elevation data can be 

downloaded as vector (point data) or as grid files. Both national and individual survey data is 

available for data held by Geoscience Australia via the Geophysical Archive Data Delivery System 

(GADDS). The DMIRS will hold data for surveys flown for the GSWA. Data can be filtered by 1:250 

000 map sheet area or by geographic coordinates. Check the projection of the dataset before you 

download, as it may default to geographic coordinates. 

 

http://services.ga.gov.au/
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Geoscience Australia geophysical data portal.  

GA have recently released a new Digital Earth Australia data portal at “eos.ga.gov.au”. It currently 

holds “Water Observations from Space Data” but additional datasets are being developed to assist 

in land management (see http:/eos.ga.gov.au/geoserver/NFRIP-WOfS/wms?). 

 

 

http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
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6.5 United States Geological Survey (USGS) 

 

The USGS hold an enormous amount of free data, most of which is accessible via its EarthExplorer 

portal (http://earthexplorer.usgs.gov/). To download the data, you are required to register (free) 

and select a username and password.  

ASTER and Landsat data are two of the remote sensing datasets available from the USGS. These 

datasets are more easily accessed via the Semi-Automatic Classification plug-in in QGIS (see 

Section 11.1). Digital elevation, radar and Lidar data are also available from the USGS. 

http://earthexplorer.usgs.gov/
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USGS EarthExplorer data portal. 

Use the Register button to create a free account or log in if you have an existing EarthExplorer 

account. Logging in allows you to download datasets. 

Enter the search criteria by using a Landsat path/row identifier, or by using the map or by a 

coordinate. Once you have selected an area, choose the data set you are seeking, add “Additional 

Criteria” if you want to filter your search, e.g.  by date range. 
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Each of the data categories have a range of datasets available. 
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If there is data available from your search request, you can then examine the thumbnails of the 

scenes and select which dataset is the best one for your purposes. The footp rint icon will show 

the area covered by the scene and notepad and pencil icon brings up a better view of the data 

including its metadata. Click on the download icon to download the data. The format of the data 

will depend on the data type and this needs to be researched by the user. 

 

6.6 European Space Agency (ESA) 

 

ESA has launched a number of satellites recently in their Sentinel series to observe the land and 

ocean areas for climate and monitoring purposes (see this site 

https://sentinel.esa.int/web/sentinel/home). For geological work, the author has found the Sentinel 

2 that most useful. The Sentinel 2 mission monitors variability in land surface conditions, and its 

wide swath width and high revisit time (10 days at the equator with one satellite  (2A), and 5 days 

with 2 satellites (2A and 2B) under cloud-free conditions which results in 2-3 days at mid-latitudes) 

will support monitoring of changes to vegetation within the growing season. The coverage limits 

are from between latitudes 56° south and 84° north (ESA). The second Sentinel 2 satellite (2B) 

has recently (2017) been launched and commissioned. 

The following description is taken from the ESA Sentinel website. 

“Sentinel-2 products available for users …..are listed in table below. 

Name High-level Description Production & Distribution Data Volume 

Level-1C 

Top-of-atmosphere 

reflectances in 

cartographic geometry 

Systematic generation and on-line 

distribution 

600 MB (each 

100x100 

km2) 

Level-2A 

Bottom-of-atmosphere 

reflectance in 

cartographic geometry 

Systematic generation and on-line 

distribution and generation on user 

side (using Sentinel-2 Toolbox) 

800 MB (each 

100x100 

km2) 

Products are a compilation of elementary granules of fixed size, within a single orbit. A 

granule is the minimum indivisible partition of a product (containing all possible spectral 

bands). 

For Level-1C and Level-2A, the granules, also called tiles, are 100x100km2 ortho-images in 

UTM/WGS84 projection. The UTM (Universal Transverse Mercator) system divides the 

Earth's surface into 60 zones. Each UTM zone has a vertical width of 6° of longitude and 

horizontal width of 8° of latitude. (see Figure 1). Tiles are approximately 600 MB in size. 

Tiles can be fully or partially covered by image data. Partially covered tiles correspond to 

those at the edge of the swath. 

http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
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Level-1C product tiling 

The continuous acquisition of Sentinel-2 image data in a given MSI mode is called a 

"datatake". The maximum length of an imaging datatake is 15,000 km (e.g. continuous 

observation from northern Russia to southern Africa). All products contain granules/tiles 

from a single datatake. A datatake is presented inside a product as a set of one or more 

datastrips (corresponding to acquisition segments downlinked to different ground stations).” 

The Sentinel 2 series A and B satellites are of relevance to geology as they have a high spatial 

resolution and 12 bands of spectral data. The multispectral imager (MSI) covers 13 spectral bands 

(443 nm–2190 nm) with a swath width of 290 km and spatial resolutions of 10 m (4 visible and 

near-infrared bands), 20 m (6 red-edge/shortwave-infrared bands) and 60 m (3 atmospheric 

correction bands). The Sentinel 2 satellites main applications are in monitoring agriculture, forests, 

land-use change, land-cover change; mapping biophysical variables such as leaf chlorophyll 

content, leaf water content, leaf area index; monitoring coastal and inland waters; risk mapping 

and disaster mapping. 
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Spectral bands for the SENTINEL-2 sensor 

Band 

number 

Central wavelength 

(nm) 

Bandwidth 

(nm) 

Spatial resolution 

(m) 

1 443 20 60 

2 490 65 10 

3 560 35 10 

4 665 30 10 

5 705 15 20 

6 740 15 20 

7 783 20 20 

8 842 115 10 

8a 865 20 20 

9 945 20 60 

10 1380 30 60 

11 1610 90 20 

12 2190 180 20 

 

The table below compares Sentinel 2 with other commonly used satellite sensors.  

Common Name Band Range (μm) Landsat 5 Landsat 7 Landsat 8 Sentinel 2 MODIS 

Coastal 0.40 - 0.45   1 1  

Blue 0.45 - 0.5 1 1 2 2 3 

Green 0.5 - 0.6 2 2 3 3 4 

Red 0.6 - 0.7 3 3 4 4 1 

Pan 0.5 - 0.7  8 8   

NIR 0.77 - 1.00 4 4 5 8 2 

Cirrus 1.35 - 1.40   9 10 26 

SWIR16 1.55 - 1.75 5 5 6 11 6 

SWIR22 2.1 - 2.3 7 7 7 12 7 

LWIR 10.5 - 12.5 6 6 10, 11  31, 32 

 

The Sentinel data can be accessed via the Sentinel portal after registration (Sign Up button), see 

this link https://scihub.copernicus.eu/dhus/#/home. 

 

https://scihub.copernicus.eu/dhus/#/home
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After logging on to the portal, scroll to your area of interest and highlight a rectangle for your data 

search. This method of data selection is less intuitive than the USGS EarthExplorer data access  

A Sentinel tile index covering the world can be downloaded as a shapefile from the ESA website. 

Sentinel 2 data is more easily downloaded using the QGIS plug-in “Semi-Automatic Classification” 

which is discussed below. 

Note that radar data is now available from the Sentinel 1 mission.  

6.7 30 m SRTM Tile Downloader 

 

The SRTM-Downloader plugin allows the user to download tiles into their map window and these 

can be saved. Note that you will need a USGS EarthExplorer portal login (free). The images are 

downloaded in one degree tiles in hgt grid format (which QGIS reads with no problem). 

You can also use this link to access the 30m SRTM tile data - http://dwtkns.com/srtm30m/. You 

will need to add your USGS EarthExplorer user name and password.  

http://dwtkns.com/srtm30m/
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These images are in jp2 (jpeg2000) format which have the image registration information 

incorporated in the file. QGIS reads and registers these images.  

  



QGIS v3 In Mineral Exploration   

 P a g e  | 25 
 

7: GEOLOGICAL DATA 

Geological data is varied in nature but is usually points, lines or polygons. Geological mapping 

comprises the collection of points using a GPS, with lines and polygons drawn as an overlay on 

aerial or satellite images. The following discussion covers a variety of tasks commonly associated 

with field data collection and interpretation. Detailed editing tasks will not be discussed as there 

are a number of resources available on the web and in the QGIS User Manual and various books. 

A variety of tips and tricks can be found in section 13. The Android tablet application “QField” is 

available and more details on this will be added in the near future. QField can be used in the field 

for data collection and mapping. 

QGIS can sometimes have problems when digitising into layers with differing projections in the 

map window. It is recommended that digitising be done on layers in one projection at a  time. The 

new file can be reprojected at a later date into a different projection if required.  

Note also turn off the auto-save plugin, if you have this enabled, as it may cause problems during 

digitising. 

Details on the digitising and editing functions can be found in the “QGIS User Guide – Release 

Testing” (for version 3.6) document which can be found here https://docs.qgis.org/testing/pdf/en/. 

This guide gets regularly updated. 

 

 

7.1 Point Data 

 

Field mapping data is collected by a number of methods. The most basic version and that used 

by the “old school” is to collect data in our field book and then enter it into a spreadsheet for import 

into a GIS. Field data collectors vary in their formats and so the user will need to determine what 

is the best option for their data import.  

GPS points are easily brought in to QGIS by importing a GPS “gpx” file or in some cases direct 

download from the GPS. Tracks and waypoints downloaded from the GPS in *.gpx format are best 

https://docs.qgis.org/testing/pdf/en/
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imported via the “GPS Tools” icon located in the left menu bar or via the top menu Vector > GPS 

> GPS Tools menu. GPX files from Garmin GPS units are usually in WGS84 geographic 

coordinates (Longitude and Latitude, decimal degree format)  by default.  

Comma separated variable or “CSV” files are a good simple way to import point data and can be 

an alternative way to import spreadsheet data when there are problems importing Excel files. If 

you do have a problem with importing an export file, save the file in CSV format and import into 

QGIS. 

Complex CSV files containing a variety of field types can be imported using CSV format files 

(*.csvt). QGIS can read field data types from an OGR CSV driver compatible "csvt" file. This is a 

file alongside the data file, but with a "t" appended to the file name extension. The file should just 

contain one line which lists the type of each field. Valid types are "integer", "real", "string", "date", 

"time", and "datetime". The date, time, and datetime types are treated as strings in QGIS. Each 

type may be followed by a width and precision, for example "real(10.4)". The list of types are 

separated by commas, regardless of the delimiter used in the data file. An example of a valid 

format file would be:  

"integer","string","string(20)","real(20.4)"  

Another option for importing csv data is to load into Excel and check the field types for each field 

before importing. Excel files are imported using the “Spreadsheet Layers” plugin. This is found 

under the Layer > Add Layer > “Add spreadsheet layer” menu. It is very important to check the 

data is being correctly imported. 

Point geological mapping data such as bedding, joints and outcrop observations can be entered 

via a spreadsheet where columns can be created to cater for items such as coordinates, 

observations and photo references. Remember to always include the datum and map projection 

data in the file. Symbol file names can also be entered into the spreadsheet that will allow QGIS 

to select the correct symbol and then orientate it using a rotation angle for the correct strike or 

plunge. An example is shown below of the WAROX (GSWA mapping data, csv format) data from 

the GSWA Bow 1:100k geological map. Additional columns would be required with symbol file 

names to allow QGIS to select the appropriate symbol, or alternatively you can choose a 

“Categorise” symbol style option and edit the symbols for each category manually. 
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Below is an example of the “categorised” features of the WAROX data for the GSWA Lissadell 

250k map sheet with features manually changed by clicking on each symbol. Once th is has been 

done, remember to save the symbols by using the “Style” button and “Save style” to a QGIS qml 

style file (e.g. GSWA_WAROX.qml). This style file can then be used to recall these styles. You 

can choose the “save as default”, which creates a qml file with the same file name as the shape 

file and when you open the shape file, the qml file will be used to determine the way the features 

are displayed for this layer. Styles can also be saved to a Geopackage file. 

 

 

To create a new empty points layer, use the menu item Layer > Create Layer > New Shapefile 

Layer and select a point layer type (very important to check the geometry type! And CRS). 

Add the required data columns and data types (text, integer, decimal number, date) to attach to 

each point. Remember shapefile column names are limited to 10 characters and any names longer 

than this will be truncated. When creating a new vector layer to digitise data, ensure the layer is 

the correct type, i.e. point, line or polygon, that it has the correct map projection and add the 

necessary columns to be able to enter the relevant field data for each feature. Save t he file with 

an appropriate file name. Note that additional fields can be added later if needed. When digitising 

into a Geopackage file the feature id will be automatically incremented. 
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Note the Type “Real”, Length and Precision options where you can  restrict the size of the data 

entered (e.g. UTM eastings length 9 - 6 figures, decimal point and two decimal places). Note that 

a negative sign, as per the dip, does not use a length, so the dip field in this example could have 

a length of 5 (00.00 to -90.00).  

Points can be moved in the map window by using the “Move Features” icon in the point edit menu. 

The layer requires to be set as editable. Note that the coordinates in the underlying table will not 

change and these coordinates need to be updated using the “Update Coordinates” option in the 

“Attribute Table”. 

 

Move tool highlighted in editing toolbar. 

If you do move points, remember to update the Easting and Northing values in the table using the 

geometry operator “$x” for Easting and “$y” for Northing. Remember to select the correct column 

to update! If you fail to do this the coordinates shown in the table will be incorrect.  Remember also 

that the updated coordinates will be in the project projection coordinates.  Also remember to save 

your edits. 
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7.2 Outcrop Photographs 

 

Photographs of outcrops and report pdf files can be attached to an observation point and allow a 

point and click to access the photo or report. In your field data file, add extra columns in the file 

for “file location” (path) and file name, so that QGIS can find the file and display it.  

There are a few of ways to display photos at points. One is using the Import Photos plugin, the 

second is going via the Layer Properties > Actions (thanks to Mike Erceg for explaining this 

process), and the other is by using the eVis plugin. The last two options require the full path to 

the file to be opened to be determined. 

If your photos are geo-tagged, i.e. they have their coordinate locations imbedded in the file, then 

the easiest option is to use the Import Photo plugin. Most smartphones take geo-tagged photos 

unless the location data option has been turned off for photos. I use a Pentax K-1 DSLR and that 

has an in-built gps, so all photos are automatically geo-tagged. 

To use the plug-in, select the directory where the photos are located, choose a suitable filename 

and press OK. The layer will them be created and using the Plug-Ins > Import Photos > Click on 

Photos (use a double click), the photos in those locations will be displayed.  
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The second method to display photos is to use the Action option, open the Layer Properties of the 

layer and select the Action tab. Double click on the Open URL – Open File option. 
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This will open the dialog box shown below. 

 

In the dropdown box near the bottom of the box, select the field with the photo location (full file 

path) and click “Insert” to put the path into the Action Text window.  

With the “Identify Features” activated for the cursor, right click on a point with a photo and the 

following will be displayed over the point. 
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Note there are two photos at this location. 

 

 

Select the “Open File” option and the photo will be displayed.  
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The third option for displaying photos is using the eVis plug-in which can also be used to display 

documents that are linked to points. eVis is located under the Database menu option on the top 

window menu. See the eVis documentation (evis_user_guide_v1.1.pdf) for detailed information 

on specifications of file locations and specifying the location of the pdf reader (if required). It is 

recommended that you also add a column to advise the user if there are photos available – such 

as a column named something like “PhotoYN”, with a yes/no answer so that you can display an 

icon indicating a photo is available for that location. Use the “Categorise” layer property option to 

show the yes-no options and change the “yes” data points to small camera icons.  

 

Example file showing relative file location for outcrop photographs.  

 

 

It is recommended to use “relative” file paths (select “Path is Relative” in the eVis options panel), 

and provide the base directory, so that if you move files to a new directory, you can update the 

base directory and QGIS will find the files. Check the tick boxes on the “File Path” and “Relative 

Path” option so that QGIS remembers these settings for the other photos in the file.  
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Other file types can also be linked, for example, pdf report files can also be attached to observation 

points (see the eVis user guide for more information).  
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A fourth method to display photos is as follows using a widget in Layer Properties > Attributes 

Form. Select the field with the file location, e.g. “PhotoFile” field, then widget type “Attachment”. 

Enter the default path to the image folder, tick “Relative paths” and “Relative to default path” 

option. 
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Scroll down the window to display “Integrated Document Viewer” and select “Image”. Leave the 

sizes to Auto. 
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Apply the changes. In the map window, use the identify icon to click on a point with a photo, then 

in the identify results window, open the form view and re-size to see the image. If the point with 

the image is not at the top of the list, select the point and then open the form.  
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7.3 Line Data 

 

Line data includes such items as contacts, faults and trend lines and are usually plotted on aerial 

or satellite imagery overlays. Surface mapping data can be digitised by scanning in the hard copy 

photo overlay into QGIS (via raster registration) and tracing the linear features, or by direct 

digitising on screen using the field mapping data as a guide. 

When creating a new vector layer to digitise the data, ensure the layer is the correct type, line 

type for example, has the correct map projection and add the necessary columns to be able to 

enter the relevant field data for each feature. Save the file with an appropriate file name. 

 

 

 

QGIS can automatically assign a unique id numbers for each line after the creation of a group of 

lines. Open the Layer Properties > Fields, select the id field and click on the field calculator icon 

and choose “Update existing field”, select the id field, select the “row number” operator in the 

Variables list. Now when you save the file it will allocate a unique id to each feature. Thanks to 

Chris Franklin for noting this feature. 
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Specific line styles can be added via the top menu Settings > Style Manager option. Geological 

line styles have been created as *.xml files and are imported using the “import” option, selectable 

from just above the Close button in the Style Manager dialog box. Import each style to a category, 

e.g. Contacts, so they are easier to locate.  
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Contact the author if you would like to download these style files for contacts, folds, joints or faults 

which are based on the USGS symbol sets. 

Note that the line direction can be reversed to get the symbols plotting on the correct side of  a 

line, e.g. fault ticks, using the “Reverse Line Direction” in the Advanced Digitising Toolbar (v3.4 

or higher). 

Line styles can also be created directly via the Style tab of the layer menu. Add an extra layer 

(using the green plus button) to combine lines and markers. There are a large number of styles 

and options to choose from. Remember to save the style using a qml or “Save as Default” option 

when finished editing the line style. 

You can combine many line styles into the one vector line file, providing you have a column by 

which the lines can be classified, e.g. feature type “contact”. 

 

 

 

Lines can be edited by first highlighting the layer in the Layers panel and clicking the enable 

editing icon (pencil). A pencil symbol will then appear next to the layer being edited in the Layers 

panel. Remember to save your edits when exiting the edit mode. When the line is editable, there 

will be red crosses on the vertices. Click on the “node” tool (seventh button along from left, next 

to rubbish bin) then click near a vertex to highlight the vertices, select the vertex you want to move 

and simply click where you want to move it to. Note QGIS v3 uses click-click not click and drag 

methodology. To add more vertices, hover over the line and click on the small red cross that 

appears. This will create a new point which can then be moved. 

See the QGIS User Manual here https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-

en.pdf for up-to-date information on editing. The Testing Version applies to v 3.6. 

 

https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-en.pdf
https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-en.pdf
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7.4 Plotting Drill Hole Traces and 3D Drill Data Display 

 

There are two options to displaying drill hole traces on maps. One is to create the horizontal trace 

and use the “Shape Tools” plugin to plot the lines, or you can use the new “Geoscience” plugin. 

Both methods are described here. 

The “Geoscience” plugin that has recently been updated (thanks to Roland Hill) to make the 

plotting of drill hole traces and colour coding of the dri ll hole traces a bit easier. The new update 

allows cross sections to be created. The drill set up screen allows you to select the collar and 

survey files. You will need to select “Experimental” plugins in the Plugin Manager > Setting tab to 

be able to see this plugin. See the documentation for more details 

(https://www.spatialintegration.com/geoscience-plugin-for-qgis/). 

If your tables have commonly used field names, then the plugin will pick the fields. 
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A De-survey option calculates the top and bottom points in xyz coordinates and the traces can be 

colour coded. The help menu for the plugin describes the work flow.  

 

The drill hole traces can be coloured via the “Symbology” tab using any attribute.  Note that when 

you import the downhole data, e.g. assays, make sure the “from”, “to” and assay values are 

recognised as numbers not text.  

To create a cross section, use the “Section Manager” and using the “Use Map Canvas” and select 

the envelope width, draw the required section line. 
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The cross section will be created in a “new” location on the map. To get back to the collar positions, 

right click on the collars layer and “zoom to layer”. 
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Surface drill hole traces can also be plotted on plans using the Shape Tools plugin. To plot drill 

hole traces, a collar file with collar coordinates, azimuth and horizontal projected distance columns 

are required. The horizontal distance – trace length – is calculated using the following formula; 

Trace length = hole length * cos(radians(dip)) 

 

Note if down dip is negative, multiply the dip by -1 (as in the above example). 
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Using the Shape Tools plugin (from icon task bar) select the Create icon and the Line tab. 

 

 

Select the Azimuth column for the hole azimuth and the distance field for the length of the hole 

trace. Check the units of distance is in metres. The result should look something like below with 

the hole traces created in a new virtual file – remember to save it with a relevant name. 
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It is also possible to display drill hole data in 3D using the QGIS2threejs plugin. All that is required 

it to have the 3D coordinates for the sample points to be calcu lated. This is a fairly basic display 

option and will hopefully be superseded with the development of the drill hole and cross section 

module planned for the future. The QGIS2threejs plugin displays the centre points in XYZ 

coordinate space. The sampling data can be coloured according to any attribute in the file, e.g. 

assay values of Cu. 

To display the downhole data, the 3D coordinates are requited for the drill hole traces. In the 

example below, the XYZ mid-points have been calculated for assay intervals. In the main map 

window, then DEM, Google Earth satellite image and the file containing the 3D coordinates of 

surface and drill hole samples have been loaded. The DEM layer and sample layer are not 

displayed (but loaded).  
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When opening the QGIS2threejs plugin, select the DEM for the elevation and right-click on the 

samples layer to select the z coordinate. 

 

 

 

 

The 3D image can then be rotated and tilted as desired. The surface satellite image has been set 

to 30% transparency to be able to see through the surface. 
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It has been noted by the author that some installations using Win7 may be unstable, and it is 

recommended to use Win10. Always remember to save your projected regularly.  

 

7.5 Polygon Data 

 

Polygon data is added by creating a new polygon layer (Layer > Create Layer > New Shapefile 

Layer or New Geopackage Layer), selecting type “polygon”, set the projection information and 

enter the additional fields for the polygon file.  Note that if you are creating a Geopackage file, it 

will auto-number every new feature when digitising. 

 

The additional columns might hold data such as geological code, geological descriptions, etc. 

Remember to select the correct field type (string, number and precision, etc) and also remember 

that field names are limited to a length of 10 characters in shapefiles – but not in Geopackage 

files. 
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Every new polygon should be assigned a unique “id” number. If you keep these unique, then it is 

easier to select and alter polygons which can be then selected by their id. Note that digitising into 

a Geopackage file will automatically number the id field.  

To add a new polygon, highlight the polygon layer in the Layers panel, and toggle the editing 

button (pencil icon). A number of polygon options are available - see the second row of menu. To 

add a new polygon, use the Add Polygon Feature icon. Hover over each icon for an explanation 

of the icon actions. If not all the digitising and advanced digitising options are not show, check the 

top menu View > Toolbars options. 

QGIS can also assign a unique id numbers for each polygon in a shape file after digitising is 

compete. Open the Layer Properties > Fields, select the id field and click on the field calculator 

icon and choose “Update existing field”, select the id field, select the “row number” operator in the 

Variables list. Now when you save the file it will allocate a unique id to each feature. Thanks to 

Chris Franklin for noting this feature. 
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If you want to calculate areas of polygons, add an “Area” column to the polygon table. Note you 

must set the projection to a metre projection, e.g. UTM, not geographic degree units, and select 

your units in the Project Properties > General > Measurements dialogue box. You can then 

populate this field by using the calculation option in the Attribute Table option. Make the layer 

editable and then use the $area function to calculate the relevant field area.  

Note that the units of area are set in the Project Properties > General > Measurements dialogue 

box. These units can be changed on the fly but you need to refresh the values in the  calculated 

area column to reflect the new units. The area can also be viewed by selecting the Layer 

Properties > Display > Field option so that the area can be displayed when you hover the mouse 

over the polygon when the Info Tool is activated. 
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Areas can also be calculated via the Calculate Geometry plugin. Right click on the layer name in 

the Layers Panel and select “Calculate Geometry”. The Calculate Geometry plugin allows you to 

select your area units. Perimeters can also be calculated this way. Make sure you do some check 

areas to ensure your results are correct. 
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To digitise a polygon, make the layer editable and choose the “Add Feature” polygon icon (4th from 

the left). Click around the polygon using left mouse clicks and finish the polygon with a right mouse 

click. Nodes can be shifted and added-deleted using the node icon, as per the line editing options.  

A drop-down list can be created in QGIS to allow for the attribution of vector items. The use of a 

drop-down list prevents typographical errors in data entry and can be used to restrict non-standard 

item names. You can use data from an existing layer or use a csv file for the source of the drop -

down box data. 

The example below shows a csv file that has been used to apply attributes to the polygon layer.  

 

In the Layer Properties, select he Attribute Form tab, and change the widget type to “Value Map”.  
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The Form Value Relation is used to apply multiple nested dropdown boxes for use in pre -set data 

entry options. This is useful for entering specific rock types, geological codes or formation names.  

The following is from North Road Consulting who ran a crowd funding campaign to get this 

into the core component of QGIS.  

What happens is you have pick lists that can change based on other values. Have a pipe? It 

can be made out of W, X, Y, and Z. Is it a Water Pipe? It can only be made of X and Z. 

Wastewater Pipes can only be made of W and Y. 

Here is my walk through. I have a point layer and that point layer has a type and a subtype. I 

stored this all in a Geopackage by the way. The type drives the subtype. You select A and you 

can only have red or blue. Maybe B is green and white. There are two tables to help with this 

process tableA is 2 fields: a primary key and a value. TableB has three fields: a primary key, 

a value, and a foreign key that relates back to Table A.  From that you can see Type A can 

only have a value of Red and Blue. Type D can only be Black and Gray. 
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The point layer has two attributes of concern: type and subtype. Type will be A,B,C, or D. 

Subtype will be a range of colours that Match the Type picked. If you right click the layer and 

select attribute forms you can assign a form for data entry. In this case for type the key 

column is the primary key and the value is the type. Note the Widget type is Value Relation! 

 

Lets looks at the subtype field. The key column is the Foreign Key (the part that relates it 

back to table A). The value column is the subtype. The magic is this – if you look at the filter 

expression:“fk” = current_value(‘type’) . See below. 
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The foreign key equals the value of the type widget. When you add a point, you’ll see the type 

drives the subtype. 

 

In summary, if you select type A, you will only get an option to select colours red and blue.  

Value Maps and Form Value Relations are useful tools for adding data. For geological data, you might 
have a list of rock classes (igneous, sedimentary, etc) and a list of lithologies (basalt, granite, 
sandstone, etc) for polygon data, or observation type (bedding, joint, vein, etc) for point data. 
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7.6 Geological Symbols and Geological Patterns 

 

Geological symbols can be either specific geological fonts (True Type Fonts) or SVG (scalable 

vector graphic) symbols. Geological symbols can be downloaded from the internet for free use in 

QGIS (https://github.com/GISsimbology/symbols). On Windows systems, geological symbol fonts 

need to be installed by right-clicking on the font file name and selecting Install .  

Geological Fonts 

Four font sets are available from Geoscience Australia and include ESRI Geology AGSO 1 to 3 

(esri_500.ttf, ESRIGA_0.ttf and ESRIGA_4.ttf), GeoscienceMining (GEOSM_.ttf) and 

MiningFossilTopo (MINIFT_.ttf). Other geological and cartographic fonts may also be available 

depending upon what other software you may have installed (previous MapInfo or ESRI fonts may 

already be installed on your system and can be used as well). 

Geological font symbols are accessed via the Layer properties > Style tab and choose the symbol 

layer type as “font”. All the fonts installed on your computer will be accessible and you will need 

to search through the installed fonts to find the relevant font file and then the relevant font symbol. 

Adjust the font size to suit. 
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SVG Symbols and Patterns 

A selection of svg geological pattern files shown in the appendix were initially sourced from Stefan 

Revets’ page (https://sourceforge.net/projects/qgisgeologysymbology/files/?source=navbar ) and 

modified to allow the overprint pattern to be coloured. Also see this page 

https://github.com/afrigeri/geologic-symbols. An alternative location for geological svg patterns is 

https://github.com/BC-Consulting/FGDC-4-QGIS. 

SVG files can be stored anywhere but the default location for the standalone install option is the 

Program folder, for example C:\Program Files\QGIS 3.6\apps\qgis\svg. Note that if you install 

QGIS via the OS4Geo option, the svg files will be located in the “C:\OSGeo4W64\apps\qgis\svg” 

for the long term release version, or the “C:\OSGeo4W64\apps\qgis-dev\svg” folder for the 

development version. It is recommended that this folder is used for the additional geological 

symbol and patterns so QGIS will find these by default and you will not require to specify and 

additional svg directory location. If you upgrade your version of QGIS, you may need to copy your 

extra svg files back into this folder. 

The image below shows the result of “Categorising” the geology and colouring each geological 

code type. 

 

https://sourceforge.net/projects/qgisgeologysymbology/files/?source=navbar
https://github.com/afrigeri/geologic-symbols
https://github.com/BC-Consulting/FGDC-4-QGIS
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Note that you have options for size and rotation of the patterns or symbols. The SVG symbols and 

patterns have discrete file names which can be used to automatically assign symbols and patterns 

in the “Data Driven Override” of the layer properties file window. 

 

 

 

Coloured backgrounds can be added to the polygon fill by adding another layer in the Symbol 

Selector dialog box. Add a new symbol layer by using the green plus symbol, and move it to the 

bottom using the down arrow key below the display box. 
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For assistance in selecting colours, go to the “Color Brewer” web site (http://colorbrewer2.org) 

where there is a vast array of colours and their specifications available.  Colour specifications can 

be specified in QGIS via their hex, RGB or CYMK number. 

If you have favourite fill styles, these can be saved as “Favorites” which are then quickly assessible 

via the Symbol Selector dialog box. 
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7.7 Geological Line Styles 

 

Linear geological features can be displayed by manually editing the line style in the Layer 

Properties > Style tab, or by using line styles set up in the top menu Settings > Style Manager 

window. Full details of how to construct various line styles can be found in a comprehensive 

document put out by the USGS and can be found here 

https://ngmdb.usgs.gov/fgdc_gds/geolsymstd/fgdc-geolsym-all.pdf. 

Style (*.xml) and symbol (svg) files can be found here at Stefan Revett’s site 

https://sourceforge.net/projects/qgisgeologysymbology/files/.  

On the main menu, go to Settings > Style Manager and select the Import option in the small box 

down on the lower left-hand side of the dialog box (looks like two blue lines with dots). Save each 

group with a name so that you can easily identify which line style group you want to display.  

 

 

Navigate to where your line styles are stored. Import each one (e.g. contact, fold, fault and joint).  

In the Symbols in group drop-down box, select GeolContacts (or whatever you called this line style 

group). Select the line style you want and hit OK. This method can be used to modify all the other 

line styles. To save these line styles remember to save the Style as default in the main Style tab 

window (under Style > Save as Default). 

https://ngmdb.usgs.gov/fgdc_gds/geolsymstd/fgdc-geolsym-all.pdf
https://sourceforge.net/projects/qgisgeologysymbology/files/
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Any of these line styles can be edited manually by selecting the layer in the top window. Note that 

you change the line direction, e.g. fault ticks on other side, by using the “Reverse Line Direction” 

in the “Advanced Digitising Toolbar”. 

 

7.8 Labelling Features 

 

Features can be labelled via the Labels tab in the Layer Properties window for each layer. There 

are many ways to place labels and format them. I will give some examples typically used in 

geological applications below but there are many other options which you are encouraged to 

explore (see QGIS User Guide – section 12.3.3 and Graser and Peterson 2016 – Part 2). Note 

that you can have the labelling panel open and docked, and when you make changes to the labels 

these are immediately displayed in the map widow. This method removes the requirement to click 

OK/apply to see changes. 

Labelling points 

The Labels tab shows a variety of labelling options such as font type and size, whether you want 

a halo around the label (buffer) which is useful when the labels are over a coloured background. 

The Formatting section allows you to specify multi-line labels and word wrap options. The 

Placement options allow you to test different ways to display your labels.  
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Note that to manually move individual labels, use the “Move Label or Diagram” option in the 

labelling toolbar. 

 

There are three placement options and it is suggested to test these options for each particular 

application. The “Cartographic” option (points only) will move labels to suit the display. If you need 

a “halo” around the labels, use the Buffer option. To rotate all the text labels, use the Labels > 

Placement > Offset from point > Rotation option. This option is useful for labelling drill holes along 

grid lines. 
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Multi-attribute labels can be created using the expression editor. Note the “Output Preview” in the 

lower left of the dialog box which shows how the labelling will appear.  
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An example is shown below displaying the structure type with strike and dip.  

 

 

 

7.9 Joining Spatial and Non-Spatial Data 

 

Joins are done via the Layer Properties dialog box. Open both the spatial file (i.e. the layer that is 

spatially located) and the non-spatial file (without spatial data). The non-spatial file can be opened 

by the spreadsheet or text file import and with “No geometry” selected. The non -spatial layer will 

appear as a spreadsheet icon in the Layer properties panel. Select the spatial layer in the Layers 

panel you wish to join, open its Layer Properties > Join tab, select the join fields (which must have 

data in common in both layers to allow it to join).  

The example below (Bow 100k map sheet) shows the join of the geological polygons with the 

geological descriptions (from an Excel file) for each of the geological codes for  the polygons. 

Individual fields can be selected for the join using the “Choose which fields are joined”. Select the 

“Custom field name prefix” and change it to a short abbreviation, remembering that shape files 

can only have a maximum field name size of 10 characters and this may cause problems later as 

field names may have been truncated. 
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After clicking “Apply”, examine the join results by opening the layer attribute table and ensuring 

the join has been successful.  

 



QGIS v3 In Mineral Exploration   

 P a g e  | 68 
 

 

To make this a permanent join, use the “Save As” option by right-clicking on the layer name in the 

layers panel, and saving the file as a new shapefile layer. If you do not save this joined file, the 

join will not be permanent, as it is a virtual join only.  

 

7.10 Geological Legends 

 

The creation of automated geological legends in QGIS has been updated. Detailed geological 

information, e.g. formation names, can be imported into the legend using the Legend tab in the 

Layer Properties > Legend tab. Note that you may have to join the geological information to the 

geological polygons, as in the case of GSWA geological data, before you create a more detailed 

legend. 
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In the window above, the label text has been selected using the “Set Labels from Expression” 

which then opens the expression builder window (below). 
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The legend will be displayed in the print layout window as shown below.  

 

 

Work is in progress to automatically assign geological patterns and descriptions from the GSWA 

polygon colouring information and pattern fills with the vector data for their digital maps. 

 

7.11 Importing and Exporting GPS Data 

 

To import points and tracks from a gpx file collected using a GPS unit, use the menu item Vector 

> GPS > GPS Tools, select the gpx file to upload and the data type ( tracks or waypoints). After 

you have imported the point or track file to QGIS, save it as a shape file to enable editi ng of this 

data. If this option is not available in your Vector tools, turn it on in the Plugin Manager.  
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To send data to your GPS device, use the POI (“point of interest”) plug-in. The plug-in allows you 

to select the layer you want to upload, the column containing the point names (or ids) and an 

optional comments column (up to 254 characters). The plug-in creates a gpx file which can then 

be easily uploaded to your gps via a direct file transfer or GPSBabel (for older models). The 

projection of the layer does not need to be in WGS84. Select the folder where you want the file to 

go, select the layer to export as a gpx, enter the filename in the “Default Categor y Name” box, 

then select the column to be used as the “POI” name. The “Optional Description Column” can be 

used to upload other columns such as a site description into the “Comment” and “Description” 

fields of the gpx file. 

 

 

If you have problems with the gpx files, you may have to download the free “GPSBabel” utility 

(https://www.gpsbabel.org/) or purchase the GPS Utilities program (http://www.gpsu.co.uk/, 

US$60). The GPS Utilities program has a vast array for GPS formats that you can read or write. 

After you imported the GPX file into QGIS, remember to save the GPS layer as a shp file to allow 

for editing of the data. 

Note that when uploading points to a GPS via a gpx file, you may need to save the shape file in a 

WGS84 (Lat/Long) projection and add two new text fields for “Name” and Desc”. Note that to 

include a long description in the DESC (Description) field, such as an outcrop observation, ensure 

you make the string length to be 254 characters. Note that some GPS units will only display a 

certain number of characters, for example the Garmin etrex Vista C only displays 30 of the 254 

characters. Copy your point id’s from your location reference column into the “Name”  field using 

the attribute table. Do the same to copy any comments into the “Desc” field. Save the shape files 

as a gpx file with GPX USE EXTENSION “YES” before uploading to the GPS. The point id’s will 

then appear as your waypoint names and the comments will appear in the notes section. 

https://www.gpsbabel.org/
http://www.gpsu.co.uk/
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Open GPSBabel and select the gpx file to be uploaded, check Device “Garmin serial/usb” and 

device name “usb”. 
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The lower window will confirm if the upload has been successful.  

A live link to your GPS can be accessed via the View > Panels > GPS Information panel with 

various connection, display and digitising options. This allows the user to have QGIS running and 

a live map link via the gps. 

 

7.12 Using the GSWA WAROX and WAMINES data 

 

The WAROX database contains the GSWA field locations, sample sites, outcrop photos and 

petrography reports. The Microsoft Access database supplied by the GSWA contains a number of 

queries to make it easier to access the data. The query “qry_photos_Locations” allows the user 

to extract the sites where photographs have been taken of outcrops. To import this data into QGIS, 

export the query as a csv (qry_photos_Locations.csv), ensuring you select the first row as field 

names, and then import this into QGIS via the CSV import option. Change the projection to GDA94 

from the default WGS84. 

In QGIS, open the layers attribute table, make editable and add another column (called something 

like “SourceFile”) of type string (text) with width of 100 characters. Save this update. This 

“SourceFile” column will hold the file location and photo number that will allow QGIS to display the 

photo for this location. The next step will concatenate the directory path and photo file name into 

the “SourceFile” column. 

Click in the column selector to select the “SourceFile” column and then enter the following 

expression in the expression editor “concat(‘directory location’||”SourceFile”) substituting the 

directory location to point to where you have saved the WAROX photos. Note you need to change 

the default back slash (\) to a forward slash (/) in the directory path or you will get “?” replacing 

the back slashes. Save the file. 

 

You may want to Categorise the points into those with and without photos using a “Rule based” 

styling using photo SourceFile is Not Null for points with photos (meaning there is a photo link), 

and no photo when SourceFile is Null (no photo link). I have used a photo icon to indicate if there 

is a photo available at a particular location. 

After saving the file, you can then use the eVis plug-in (Database > eVis > EVis event id tool) to 

click on and display photos linked to that site. An example below shows the WAROX points 

displayed to indicate whether a photo was available at that location.  
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A similar process can be used to display linked petrographic reports and photos in the WAMINES 

database. See below an example from the WAMINES database. To display pdf files, you will need 

to add the pdf display program in the “Configure External Applications” tab. 
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7.13 Converting Local (Non-Earth) Grids to Real World Coordinates 

 

There is no easy way to convert non-earth coordinates but there is a way by using the v.transform 

algorithm. The algorithm requires an x, y coordinate for the grid origin and an optional rotation 

amount. This data is usually available from the mine surveyor or can be calculated. The author 

uses a small python program that uses 2 common sets of points to calculate a grid origin and 

rotation amount. The work flow below is for point data and within one UTM zone in metre 

coordinates only. 

Using a new project workspace, change project projection to “no projection” then open the local 

grid file using the local coordinates (e.g. drill holes in local coordinates). Check that the local 

coordinates in the map window look correct. 

Run the v.transform algorithm with the points in local grid coordinates. To find this algorithm 

display the Processing Toolbox in the RHS of the map window, type v.tr in the search box and 

the v.transform algorithm should now be displayed. Double click on it to open the v .transform 

dialog box. Use the parameters for x, y and rotation. 

Allocate the new projection to the points by firstly, setting the projection of the transformed 

layer to your desired UTM projection (very important to do this first) via the Layer Properties > 

Source tab, then change the project projection to your UTM projection. Close the original local 

coordinates file and zoom to the extent of the new transformed layer to check the transformation 

was successful.  

This will produce a transformed (virtual) layer which will need to be “Exported As” to save the file 

permanently. 

 

7.14 Creating a Grid Layout 

 

A regular grid of points can be created via a table of coordinates or using the “Regular Points” 

algorithm. Other create grid options are available in the Processing Toolbox, but these two 

methods are the simplest. 

To create a grid, from a table of coordinates, use the “Create points from Table” algorithm located 

in the Processing Toolbox under the Vector Creation list. Input the table that contains the 

coordinates, select the X and Y coordinate fields, with optional Z and M fields as well, check the 

CRS and run. The algorithm will create a series of points with id’s  only. Use the attribute table to 

add Easting and Northing fields if desired to attach the point coordinates. 

To create a grid of points using the map window, use the “Regular Points” algorithm in the Vector 

Creation list. The extent of the grid can be entered manually or defined by the map window extent. 

Set the grid spacing and check the CRS and run. The resulting grid can be rotated (using the 

Vector Geometry > Rotate algorithm) or the “Rotate Feature” on the map window icons (next to 

the “Move Points” icon). Both methods allow the user to select the point for rotation and the amount 

of rotation. 

If you want to create non-square or hexagonal grids, for example, use the “Create Grid” option 

under the Vector Creation options. 
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8: DISPLAYING GEOCHEMICAL DATA 

Geochemical data is usually in the form of an excel spreadsheet or as a text file. Open the file in 

QGIS via the “Spreadsheet Layers” or CSV file open options depending upon the format of your 

data. See section 6 above for opening spreadsheet and csv files, and the potential use of CSV 

format files (*.csvt) for large complicated csv files.  

IOGAS has supplied a trial QGIS plugin for its export files and this is currently being tested. 

Hopefully it will be due for public release soon. 

When loading your data, ensure the data has been loaded into QGIS as the correct field type, i.e. 

as a number, not as a string (text) field. This can be checked using the layer’s Layer Properties > 

Fields tab. 

When the data has been imported into QGIS, make sure you check the correct coordinate system 

has been selected and the data is in the correct place. Google Earth, satellite imagery or open 

street map vector data can be used for this purpose. The simplest display is a series of points 

where the symbol can be displayed in different colours and sizes by sample value.   

Geochemical point data can be displayed as points and can be coloured or sized according to 

value. Use the Layer Properties > Style tab to select the way you want the data displayed. The 

simplest way is to use the “Graduated” option and colour the point values. Note that this works on 

numeric values only. Select the column you wish to colour the points by and the desired colour 

ramp and hit the “Classify” button. Under the display window, you can also select the way the 

points are coloured. You can use a variety of methods. You can also manually edit the ranges in 

the display window. 

If you select 8 classes and the “Quantile (Equal Count)” method this will calculate the 1st and 3rd 

quantiles as the second and seventh quantiles. For example, the displayed data set has a first 

quantile value of 10 and a third quantile value of 66. The Inter-Quantile Range (IQR) is therefore 

56, and by calculation, the anomalous data threshold of “Cu_ppm” is 3rd Q + (1.5 * IQR) = 84. 

These values can be checked by using the Statistics Panel.  
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Statistics can be carried out on geochemical data in QGIS. Univariate statistics can be calculated 

using the View > Statistical Summary panel. This opens a panel under the browser panel, where 

you can select the layer and data field for which field you want to calculate statistics. The mean, 

standard deviation, first quantile, third quantile and the Inter Quartile Range (IQR) are among 

some of the calculated results.  
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Note that the user must ensure their data has been verified and checked, so as not to introduce 

anomalous results caused by below detection assay results, e.g. “-5” as a replacement for below 

detection at a 5 ppm detection limit. In this example of Cr data, I have filtered the data to only use 

data > 0 to avoid the below detection and not assayed (-999 type codes).  
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Geochemists traditionally use “box and whisker” plots to display the mean, median, first and third 

quantile, interquartile range (IQR) and anomaly threshold level (third quartile plus 1.5 times IQR).  

The IQR is the difference between the third and first quantiles.  

 

Gridding of geochemical data is common where there are a large number of approximately regular 

located sample points. Gridding can be done via the Processing Toolbox > SAGA > Raster 

creation tools. A large number of gridding options are available and one I have used most often is 

the “Multilevel b-spline interpolation”. If the Processing Toolbox is not displayed, go to the top 

menu Processing > Toolbox. 
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Each gridding method will have parameters specific to that method and the user will be required 

to know what effect each parameter will have on the resulting grid.  
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The created grid is not clipped to the data but this can be achieved via the Raster > Extraction > 

“Clip raster by mask layer” menu item. The image below shows the grid clipped to the data but a 

user created polygon mask would probably produce a better result.  

 

 

 

QGIS v3 allows for the plotting of data via the Data Plotly plugin. Various plotting options are 

available. The image below shows a simple scatter plot of Cr vs Ni.  
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Data points selected on the plot can be highlighted on the map.  
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Other example plots are shown below are from the DataPlotly site. 

 

Scatter Plots 
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Box Plot with Statistics 

 

 

Stacked Bar Plot 

 



QGIS v3 In Mineral Exploration   

 P a g e  | 86 
 

 

Probability Histogram 

 

Pie Charts 
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2D Histogram 

 

Polar Plots 
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Ternary Plots 

 

 

 

Overlapped Plots 

 

 



QGIS v3 In Mineral Exploration   

 P a g e  | 89 
 

 

Subplots in Columns 

 

Subplots in rows 

The html code is available to allow these plots to be added to other documents. The help files are 

located in the “?” tab of the plugin. 
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9: GEOPHYSICAL DATA IMPORT AND DISPLAY 

9.1 Data Import 

 

Geophysical data usually comes as located data files (text) or grid files. QGIS can read many grid 

formats with *.ers, and *.tif (geotiff) files the most common, and these can be loaded by dragging 

the file name from the Browser Panel into the map window. Note that Geosoft *.grd files require 

conversion to *.ers files via their free viewer Oasis Montaj program (available from 

www.geosoft.com). 

When opening located data text files, remember that shape files can only have column names up 

to 10 characters in length. If your text files have longer column names, then it is suggested you 

use a free text editor like Notepad++ (https://notepad-plus-plus.org/) to modify the field names.  

Grid files are treated as raster files and are usually displayed as greyscale by default. To change 

the display, open the layer properties dialog and select “Style”. A var iety of options are available 

including changing the colour ramps, colour stretch and display value limits. For a coloured image, 

use the Render Type > “Singleband Pseudocolour” option.  

 

 

9.2 Colour Ramps 

 

Additional colour ramps are available by clicking on the down arrow to the right of the “Color 

ramp” dialog box and selecting “Create New Color Ramp…”, select “Catalog: cpt-cty” from the 

drop-down box to display a variety of available colour ramps.  

http://www.geosoft.com/
https://notepad-plus-plus.org/
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Colour ramps have also been developed by the Centre for Exploration Targeting (CET) in Perth 

that have better colour perception. These can be reviewed and downloaded from here 

“https://peterkovesi.com/projects/colourmaps/”. Download the QGIS xml file and import via the 

Options > Style manager dialog box. My preference is to use the CET-R1 to CET-R3 ramps 

which are rainbow style colour ramps and they have the blue to magenta colour ranges which 

work well for shading magnetic images for example.  

 

 

The “bcry” and “bgyr” are also good options for colouring geophysical data grids. Select 

the “Save as standard gradient” tick box in the lower left of the dialog box, then the 

Save Color Ramp. 

https://peterkovesi.com/projects/colourmaps/
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Save the color ramp with a name, e.g. default colour ramp, and “Add to favorites” so it 

shows up on your quick colour ramp select options. 
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Note that you can use the information icon to examine the values of a pixel or grid location. If the 

value is not displayed in the Identify panel, try minimising the left-hand side column, as sometimes 

the column width is too wide for the panel to display the cell value on the right-hand side. 

 

If you open a grid file and have difficulties displaying the data, e.g. with 1VD magnetic images, 

zoom in to a small area of the grid and then “Stretch to Current Extent” (available as a right click 

on the layer name in the Layers panel) to stretch the data to something visible.  

9.3 Custom Data Stretch 

 

The Raster toolbar has a collection of basic display options to change how the image is displayed.  

Images can be stretched to the entire image or window extent. See the mouse over for how these 

icons work. 

 

Display settings can also be selected in the Symbology tab of the Layer Properties. 
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9.4 Profiling Gridded Data 

 

To obtain a profile across any gridded data, use the “Profile” plugin. Open the Profile plugin 

(usually on the menu bar) and use the “Add Layer” button to add the layer from  where you want 

the values extracted. Draw a line using one click to start and a double click to complete the line.  

The resulting profile values can by copied to the clipboard (under the Table tab) for use in 

programs like Excel. 
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9.5 Creating Stacked Profiles and Colour Bars 

 

Creating “stacked profiles” of data, especially magnetic data is important for the identification o f 

small discrete features in wide spaced aeromagnetic data. One example is in the search for 

kimberlite pipes in regional (>300 m) spaced line data.  

This algorithm has been created by Benoit at GeoProcessing (http://www.geoproc.com/qgis.htm) 

in South Africa and is part of their “GeoProc” toolset. The stacked profile tool allows the user to 

import located line data to plot stacked profiles of the data. It is important that the located data is 

in "point" format not multi-point data format.  

Coloured bar scales can also be created for coloured images using the Composer > Create 

Colour Scale Bar” tool. There are some dependencies that require installation for these to work  

so please read the installation instructions. The plugin loads the menu items into the Processing 

Toolbox. 

 

 

  

http://www.geoproc.com/qgis.htm
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10: 3D IMAGE DISPLAY 

QGIS v3 now has a 3D view capability built in as a standard part of the program (3d Map View) or 

by using the QGIS2threejs plugin. The options for the 3D Map View are limited at this time but a 

recent crowd funding effort has enabled planning and extra programming for the 3D options to be 

greatly improved. The QGIS2threejs is the best option at this time for viewing geological data in 

3D. Downhole drill hole traces can be displayed if the 3D coordinates have been calculated.  

10.1 3D Map View 

 

The layers require to be projected, i.e. not a geographic projection, lat/long, and they should all 

be in the same projection.  

To run the 3D view, place the layers into the map window with the DEM layer at the bottom of the 

layer stack. Go to the View > New 3D Map View menu item and create a 3D map window. Resize 

the window to suit and select the little spanner symbol to open-up the options dialog. 
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Select the layer to be used as the “Elevation”, set the vertical exaggeration and press OK. Use 

the hand icon to move the display in the window. To tilt the display to see the 3D effect, hold the 

shift key and drag the mouse towards down. With the shift key depressed you can also rotate the 

image. Scroll speed will be dependant upon the size of your grid files and the speed of your PC. 

 

Any image displayed in the map window can be used for 3D display.  
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10.2 QGIS2Threejs Plugin 

 

This plugin is more flexible than the 3D map view at the present stage of its development for 

geological application. The layers require to be projected, i.e. not a geographic lat/long projection, 

and they should all be in the same projection. If you have data in 3D, i.e. with x, y and z 

coordinates, then this plugin can display the data. If you get weird effects, you may have a lat/long 

layer in the map window which may be causing problems. Close any lat/long layers and re-run the 

plugin. 

To use this plugin, load a DEM or any type of grid file over which you would like to drape data. 

For example you may wish to drape a satellite image or geological map over a digital terrain model 

 

Make sure the grid is on the bottom, with the layers to be draped on top of the DEM/grid layer. 

Run the QGIS2Threejs plugin and select the DEM layer.  

Vertical exaggeration can be changed using the Scene > World Settings dialog box. 
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If you have vector data with a z (e.g. RL or elevation data) then right click on the vector layer name 

in the QGIS2Threejs window and se lect the z value to use in the “Z Coordinate” options. Downhole 

drill hole data can be plotted using this method.  
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The image below shows a Google Earth image, draped over a SRTM digital terrain model, with a 

vector file of surface samples and drill hole sampling. 
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11: REMOTE SENSING 

The availability of free satellite and other remote sensing data has created unique opportunities 

for the display of this data to assist geological interpretation and analysis. QGIS can display the 

normal satellite images but it also has a powerful plugin, the Semi-Automatic Classification (SCP) 

plug-in, which can be used to source, select, download and process satellite imagery.  Video 

tutorials are available on the web (https://www.youtube.com/watch?v=GFrDgQ6Nzqs) and cover 

a variety of remote sensing applications including land cover classification.  

To download ASTER and Landsat data, you are required to register (free) at the USGS 

EarthExplorer portal. These registration details will be required to be entered on the SCP 

download/login window. Sentinel data download requires (free) registration at the ESA Sentinel 

data access portal. Note that it might take three or four days for your registration at ESA to become 

active. Recently, the search times on the ESA site via the SCP plugin have been very slow and it 

has been my experience lately that the USGS EarthExplorer portal is the fastest way to select and 

download ASTER and Sentinel data. 

11.1 Using the Semi Automatic Classification Plugin 

 

Selection, downloading and processing of satellite remote sensing data can be achieved using 

the Semi Automatic Classification Plugin (SCP) written by Luca Congedo 

(https://fromgistors.blogspot.com/p/semi-automatic-classification-plugin.html). After installing the 

plugin you can open the plugin via the main menu bar. Note the plugin automatically adds panels 

and toolbars which I normally close to free up window space.  

 

The main SCP window shows tabs for downloading data, as well as a variety of other pre and post 

processing options, band calculations and tools for land cover classification. 

To download data you need to register with the USGS via their EarthExplorer portal (free 

registration, http://earthexplorer.usgs.gov/) for ASTER and Landsat data and with the European 

Space Agency (ESA) via their Sentinel data access portal 

(https://sentinel.esa.int/web/sentinel/home). Enter these login details into the relevant sections of 

the SCP Download Products > Login data tab. Make sure you click “Remember” so you don’t have 

https://www.youtube.com/watch?v=GFrDgQ6Nzqs
https://fromgistors.blogspot.com/p/semi-automatic-classification-plugin.html
http://earthexplorer.usgs.gov/
http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
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to re-enter your login details each time. Note also that logins with ESA make take a couple of days 

to initialise. 

 

 

Once all the logins are complete, then you are ready to download data. Have the area that you 

wish to obtain data displayed in your QGIS map window as we will create a search area directly 

into this window. Click on the Search tab of the Download Products window. 
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The required product can be selected via the “Products” dropdown list. To select a search area, 

click on the orange-red cross in the top RHS of the window, then left click the top left hand side 

of the map area, then right click on the lower right hand side to set your search area. This will then 

populate the search area parameters. 
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You can further refine your data search by entering for example a Sentinel 2 tile number into the 

“Filter” window to speed up searching and ensuring you only download the required tiles. You can 

select the maximum allowable cloud cover and any date ranges. Note that for ASTER data only 

download data prior to 1st April 2008 as the SWIR became non-operational after that date. 

Once you have selected the search area, open the “PreProcessing’ window.  

 

 

The Preprocessing window allows SCP to do atmospheric and other adjustments to the source 

satellite data after download, e.g. DOS 1 atmospheric correction on Sentinel 2 data. Note that 

preprocessing will only occur if the “Preprocess Images” check  box is ticked in the Download 

window. Note also the other check boxes to limit what gets downloaded and what is displayed in 

the map window. 

Once you have set your search parameters, click the “Find” icon.  

 

 

SCP will search the data for tiles fitting the search parameters. The time to retreive the data will 

depend upon internet speed. If you get a time-out error or cannot connect type message, check 

your login details. 
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A list of selected tiles will be shown in the ProductID window and each item can be highlighted 

and viewed in the RHS window. Check that the scene is suitable, e.g. no cloud over your area of 

interest, then click the icon “Display preview of highlighted images in map”. This will then download 

a low resolution full scene image into your map window to ensure it covers the  correct area. 

 



QGIS v3 In Mineral Exploration   

 P a g e  | 106 
 

To download this data, return to the Download products window and make sure the “Download” 

“Only if preview in Layers” is checked on. This will ensure only those layers you have in the map 

window will be downloaded. If all OK, click the run button and save it to the required location. The 

download and pre-processing may take some time, 10-20 minutes, and it is advised not to use 

QGIS during this time as it may crash the process. Other programs on your PC may be used.  

The download process will entail downloading all the band data, then running the selected 

corrections, before displaying the final set of image bands into your map window. These bands 

can then be used to create RGB images and allow band ratios to be calculated.  

The SCP Plugin also allows the user to do a multitude of other task including Principal 

Components Analysis (PCA). Note that to use PCA all the images must have the same pixel size 

and this may require “resampling” of the image (use the Processing Toolbox > SAGA > Raster 

Tools > Resampling algortithm). 

11.2 ASTER Data 

 

Details of the ASTER (Advance Spaceborne Thermal Emission and Reflection Radiometer) 

scanner bands are shown in the figure below (from Abrams and Hook 2016). 

ASTER data is now freely available worldwide but note that the SWIR sensor (bands 4 to 9) 

became inoperable on 1st April 2008, and therefore only data acquired before this time will 

be suitable for mineral mapping. 
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An example of ASTER band combinations using ratio 4/7 (red), 4/3 (green) and 2/1 (blue)around 

the Argyle mine area. 

ASTER bands and band ratios for geological applications are shown in the tables below (from 

ASTERDataProcessing_GA7833.pdf available from Geoscience Australia).  
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Band rations are easily calculated in the SCP plug-in. My personal experience for using the 

ASTER data in Western Australia and Peru, is that the discrimination ratios using ratio 4/7 (red), 

4/3 (green) and 2/1 (blue) works well in most situations. The AlOH minerals/Advanced argillic 

alteration combination and the Alunite-Kaolinite-Pyrophyllite image also works well for detecting 

alteration associated with porphyry copper mineralisation.  
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Other possibly useful ASTER band calculations and combinations are listed below. 

Abrams Ratio – 5/7, 4/5 and 3/1 in RGB 

Sabin Ration – 5/7, 3/1 and 3/5 in RGB 
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Mineral Indices of Ninomiya (2004) 

 OH Minerals Index – (Band 7/ Band 6) * (Band 4/Band 6) 

 Kaolinite Index – 4/5 * 8/6 

 Alunite Index – 7/5 * 7/8 

 Calcite Index – 6/8 * 9/8 

Porphyry Alteration Index – 4, 6 and 8 and RGB (advanced argillic and phyllic alteration in pink to 

red colours) 

Alunite and kaolinite enhanced by 4/5 or 4/6 

Sericite – phyllic alteration enhanced by 5/6 

Propylitic alteration enhanced by 5/8 

 

Remember the resulting images may have artefacts caused by low sun angles, clouds, etc. 

so be cautious in using the data. Remote sensing vendors can undertake more advanced 

processing and interpretation of this data, and the rough processing described herein 

should be used with caution. 

 

11.3 Landsat Data 

 

Landsat 8 data is collected over 11 bands as illustrated below. 

 

Landsat 8 band combinations are usually bands 4, 3 and 2 in the R, G and B channels for an aerial 

photo type image, whereas the combination of bands 6, 4 and 2 typically enhances the geology. 

Band 8 is used to pan-sharpen the 30 m images to 15 m resolution. The SCP plug-in will 

automatically pan-sharpen the RGB images if this option is selected. 
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11.4 Sentinel 2 Data 

 

The Sentinel 2 satellites are designed for earth observation and the figure below illus trates the 

comparison with the other satellite data bands (from van der Meer et al 2014). The Sentinel 

satellite constellation has been launched by the European Space Agency (ESA) and the derived 

data is available free of charge. See ESA website (https://sentinel.esa.int/web/sentinel/home) for 

more detail on the available data and data access. You need to register (free) on the Sentinel web 

site to be able to download the Sentinel data. 

 

When using Sentinel 2 data, it is recommended to use bands 4, 3 and 2 (for RGB) for the natural 

aerial photo type image and a combination of bands 12 or 11, 4 and 2 (for RGB) which can 

enhance the geology in a scene. Users should experiment with various band ratios to find which 

is the most suitable for their application.  

The following list of recommended band combinations is from the Sentinel education web page 

(https:/Sentinel-hub.com/develop/education).  

Natural Colour B4 (red), B3 (green), B2 (blue) 

Colour Infrared (vegetation) B8, B4, B3 

False Colour (Urban) B12, B11, B4 

Agriculture B11, B8, B2 

Vegetation Index (B8 – B4)/(B8 + B4) 

Moisture Index (B8A – B11)/(B8A + B11) 

Geology B12, B4, B2 

Bathymetric B4, B3, B1 

Atmospheric Penetration B12, B11, B8A 

SWIR B12, B8A, B4 

NDWI (B3 – B8)/(B3 + B8) 

SWIR-2 B2, B11, B12 

 

The figure below from van der Meer et al 2014 compares ASTER ratio mineral mapping to the 

equivalent bands in the Sentinel 2 data. 

 

https://sentinel.esa.int/web/sentinel/home
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11.5 Creating RGB Images 

 

There are two methods available to create a coloured image (“rgb”) of remote sensing or any 

other 3 band data set. We can use the Raster > Miscellaneous > Build Virtual Raster option or 

the “Vitual Raster Builder” plugin. Ensure you have the files in the correct order as it assigns the 

red channel to the lowest image, green to the middle image and blue to the upper image in the 

Browser panel. 

The Raster option is shown below. 
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The Build Virtual Raster window will be displayed. Select the input layers as the ones to use for 

the RGB composite.  
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Select the “Highest” resolution to ensure you obtain the highest resolution possible and is similar 

to “pansharpening” where the larger pixels will be resampled to match the smaller pixels. Press 

“Run in Background” and the composite colour image will be produced as a virtual image.  

To save this file permanently, you need to right-click on the “Virtual” file name and save as a 

chosen file format, usually GeoTiff. 
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To adjust the colour stretch, zoom into a part of the image where you want to see more detail and 

then use the Layer panel to right click on the RGB layer and select “Stretch using current extent”. 

This can be done multiple times until you get the desired result (see below for example).  

Alternatively you can activate the “Raster Toolbar” and use the toolbar to adjust the colour stretch.  

 

The “Virtual” RGB image is currently only a temporary file. To create a permanent image, right 

click on the image layer in the Layers panel and select “Save As” Select the “Rendered Image” 

option, click the “Browse” and select the folder and required file name. Change the coordinate 

system if required. When all is OK, click OK. It may take some time to create the tiff file depending 

upon the size of the image and the speed of your computer.  

The other option for producing the RGB image is by using the “Virtual Raster Builder” plugin.  
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Add the files via the “Source Files” tab and these can be renamed in the left hand side window 

for reference purposes, e.g. Band1 can be renamed to Band12. The RGB creation is done via 

the “Output” tab and this creates a temporary virtual file. 
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The resulting RGB image can be saved via the Save Raster layer option.  

 

Note there are options for saving as a geopackage or GeoTiff file and modifying the output 

projection Geopackage files are much more compact (smaller) than equivalent GeoTiff files.  

To merge adjacent satellite images/bands, use the Processing Toolbox > SAGA > Raster tools > 

Mosaic raster layers. Option settings that have worked in merging adjacent ASTER scenes are 

Interpolation – “4 B-Spline”, Overlapping areas – “6 feathering”, Blending distance – “1000”, Match 

– “regression”, Cell size – “15” (or 30 m, 60 m, 90 m - to match the relevant pixel sizes for the 

images being merged), Fit – “Cells” and save to a file. All other setting as default. 

If you have problems merging adjacent satellite images where you get edge effects between 

adjacent scenes, try downloading and installing SAGA (http://www.saga-gis.org/en/index.html). 

This a powerful and free GIS analysis program and has a good help file 

(https://sourceforge.net/projects/saga-gis/files/SAGA%20-

%20Documentation/SAGA%205%20User%20Guide/. The mosaicking option is found in the 

http://www.saga-gis.org/en/index.html
https://sourceforge.net/projects/saga-gis/files/SAGA%20-%20Documentation/SAGA%205%20User%20Guide/
https://sourceforge.net/projects/saga-gis/files/SAGA%20-%20Documentation/SAGA%205%20User%20Guide/
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Geoprocessing > Grid > Grid System > Mosaicking menu item. Use the Match option “match 

histograms of overlapping area”. 

 

11.6 Principal Components Analysis (PCA) 

 

Principal Components Analysis (PCA) can be undertaken using the Semi-Automatic 

Classification plugin. The input files for the PCA analysis require they have the same pixel size 

and may require resampling if necessary (see Processing Toolbox > SAGA > Raster Tools > 

Resampling). 

If you need to resample the raster to a different cell/pixel size, ensure you check the Cellsize 

and “Fit” to cell, otherwise it will offset the resulting image. 

 

 

In the SCP plugin, create a Band Set using the Band Set tab. Press refresh to show what bands 

are available (in the Layers panel) then select the layers to be used for the band set – highlight 

the required bands, then click the plus symbol “Add  band to band set”. This set of bands will be 

used in the PCA analysis. 
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Click on the Band Processing tab and select PCA. Check that the input band set is correct, 

select 3 components (required for an RGB colour image) and press Run. Select the target 

directory for the results to be saved. Note in the image above I have used the SWIR ASTER 

bands for the PCA analysis. 

 

This process will produce three PCA images, PCA1, PCA2 and PCA3. Use the Virtual Raster 

Builder plugin to produce the RGB image (as above). 
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12: MAP PRODUCTION 

12.1 Print Layout 

 

The Print Layout is the tool to produce maps for output. Various standard page sizes can be 

selected as well as creating custom sizes. Everything to do with the final map design is done in 

the print layout. Map creation is described in Hands-On Workshop 1. If you lose tab views, click 

on the “Views” menu option in the layout window and scroll down to Panels to reselect them for 

display. 

To ensure you get true scale plots, it is important to have the main map projection in a metres 

projection (i.e. UTM) and not in a geographic lat/long projection. Problems may be created with 

the scale not being correct on the map output when the main map window is in a lat/long projection.  

12.2 Map Templates 

 

Templates can be constructed for use with a variety of map sheets sizes, e.g. A4, A3, A2, A1 and 

A0 in either landscape or portrait orientation. Frames and title blocks are simply constructed as 

rectangles and standard text boxes added into the rectangles. Shapes and text boxes are selected 

from along the left-hand side margin of the map composer window. The figure below illustrates an 

example of a template complete with title block. Templates can be dragged into the print layout 

window from the Browser panel, which will then automatically set the correct page size. 
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Each item of the template is listed in the Item panel and can be turned on or off and edited. Note 

that the position of the features can be set and adjusted using the “Position and Size” options in 

the item properties dialog box. Each item, e.g. page frame, insert box, logo, etc., has its own item 

properties and these can be varied independently.  

 

 

The image above shows all the items that map up the map frame. 
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The example above is the “Logo” item (diamond image on the layout) and its location is referenced 

to the top left-hand corner of the page as shown in the 3 x 3 box array. It is located 215 mm to the 

right and 152 mm below the top left hand corner of the page, with a width of 8 mm and a height of 

7 mm. 

Each text box has a location and is edited as required in the Label > Main Properties window. The 

image below shows the “Author” field selected and the details can then be added to the existing 

text, or changed as required. If the text boxes require adjustment, use the position and size options 

attached to the item. 
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Note that these templates may require adjustments for different printers and plotters depending 

on their “print area”. 

The position and size of the inserted map window can be adjusted under the “Map” item properties 

and using the “Position and Size” options. The reference point in the figure below shows the 

measurements from the top LHS of the page. 
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12.3 Layout Manager 

 

The layout manager shows what layouts are attached to the project. You can have many layouts 

of different sizes and configurations all saved with the project. If you have a set layout where 

you need different themes on maps, you can use the duplicate button to make a copy of the 

layout. Note that you need to “lock” layers in a layout to prevent a refresh from re-drawing the 

layout display. 
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13: MISCELLANEOUS TRICKS AND TIPS 

Access Databases 

Connecting to an Access database requires some additional steps than required for the open 

source database programs.  

Open the 64-bit ODBC admin window (via the Windows search box) and add the Access database 

name and location in the User DSN tab – e.g. “LateriteChem”. 

 

In the Open Data Source Manager, select the Add Vector option, and type of Database. Connect 

to the database and Add. 
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The next window will display the tables available for import.  

 

If the table has spatial data, e.g. coordinates, then after import, use the Processing Toolbox > 

Algorithms > Vector Creation > Create Points Layer from Table, and select the field for the 

coordinates and the applicable Coordinate Reference System. 

 

AutoSaver Plug-In 

The Auto-Saver plug-in will save your project at regular intervals. I have had problems with this 

turned on during digitising and I recommend it is turned off when creating new files.  
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Bookmarks 

Bookmarks are used to remember the extents of a map window and they are saved with the projec t 

data. When a bookmark is saved, the bookmark list panel is displayed. Bookmarks are created 

via View > New Bookmark. 

Colour Ramps 

To add additional colour ramps to the default option use the “Create New Colour Ramp” from the 

drop down box to the right of the Color Ramp selection box,. The preset colour ramps are shown 

in the “Color Ramp” dialog box and I recommend the Catalog: cpt -city option which will display 

the next dialog box.  

There are many different groups to select from, but I prefer the QGIS tab, and the continuous 

colour bands, e.g. “bgyr”. 
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New colour ramps can also be imported via the Style Manager dialog box.  

The Centre for Exploration Targeting (CET) in Perth have developed colour ramps that are better 

for visual perception (see this link https://peterkovesi.com/projects/colourmaps/). They are 

https://peterkovesi.com/projects/colourmaps/
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available in a QGIS xml format that can be imported via the Style Manager. These styles can then 

be access as favourites. My preference for data grids such as magnetics is to use the CET-R1 

colour ramp. 

 

 

Colour Selection 

To assist in selecting colours for maps, you can visit the ColorBrewer website 

(http://colorbrewer2.org) where rgb, hex and cymk values of a huge variety of colour options can 

be viewed and selected as required. 

Data Searching 

When searching large datasets, a number of options can be used. Spatial searches can be done 

in your map window but text searches are best done via the Expression form. 

Highlight the layer in the Layers panel, bring up its attribute table and click on the “Select Features 

Using an Expression” button. 

 

 

 

This will bring up the expression editor window. Click on the central panel to select the field to 

search in, then press “all unique” in the lower right hand side of the dialog box to show all the 

entries in this field. You can filter by entering values into the “Values” window. Double click the 

http://colorbrewer2.org/
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field name to enter it into the left hand panel. Use the function button to add a function, e.g. “=” 

and then double click on the value to search for in the right hand panel. Hit select to run the query.  

 

 

Go to the attribute table and select the “Move selection to top” of the table. This may take a little 

while in large datasets but it will display the selected record(s) at the top of the table and highlight 

them.  

 

 

To show these on the map, select the “Pan map to selected rows” icon and the map will pan to 

the area of the selected features. 
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Digitising Toolbar (PlugIn) 

Every tool is activated as soon as the active layer is of an appropriate type and in edit mode. Keep in 
mind that some tools need that the current layer's CRS matches the project CRS. 

As a general rule of thumb your editing layer's CRS and the project's CRS should match. It makes 
life easier. If you need results in a different CRS, transform the layer after you have finished your 
digitizing session. 

All edits can be undone/redone using QGIS' standard undo/redo capabilities. 

Description of the tools 

Split multi part to single part 

applies to: MultiPoint, MultiLine and MultiPolygon layer 

1. batch mode: The selected multi-part features in the active layer are split into single part and 
added to the layer as new features, keeping the attributes of the original (multi-part) feature. 

2. interactive mode: click on any multi-part feature. The feature will be split into single parts 
which are added to the layer as new features, keeping the attributes of the original (multi-part) 
feature. 

Split off one part and add it as new feature 

applies to: MultiPoint, MultiLine and MultiPolygon layer 

Click on any part of a multi-part feature. The part will be deleted from the original feature and added 
as a new (single-part) feature to the layer keeping the attributes of its parent (multi-part) feature. 

Split features 

applies to: Line, multiLine, polygon and multiPolygon layers 

Works exactly like Split Features tool in QGIS' Advanced Digitizing Toolbar when applied to non-multi 
features. When applied to multi features the user is asked via a dialog (see below) which of the newly 
created geometries (fraction of a part) should become the new feature. The other fraction stays as 
part within the original multi feature. Thus it replaces QGIS' Split Parts, too, which is of limited use, 
because its application results in an invalid geometry if the split-off part is not edited any further. The 
dialog shown when splitting multi-part features has four buttons: 

1. Cancel aborts the current splitting operation and leaves all features untouched.  
2. No to All aborts the splitting of the current feature and leaves it untouched. 
3. No leaves the currently highlighted fraction in the multi-part feature. 
4. Yes accepts the currently highlighted fraction for becoming the new feature. 

Merge selected features 

applies to: any layer with a primary key field, i.e. a database layer 

This works as the Merge selected features button in QGIS Core, except that Core's Merge selected 
features deletes all selected features and then inserts a new feature. DigitizingTools' method offers 
the user to choose which feature to keep by choosing its primary key value. This feature's geometry is 
updated with the combined geometry of all selected features, while all other selected features are 
deleted. This feature will be removed once #13490 is closed and implemented. 

http://hub.qgis.org/issues/13490
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Exchange attributes between selected features 

applies to: any vector layer 

Exchanges the attributes between two selected features of the active layer. Reasoning: when splitting 
features in a layer coming from a database provider the user can thus control which feature is going 
to keep the primary key value (important for related tables). 

Cut with polygon from another layer 

applies to: line and polygon layer (multi or single part) 

Choose another layer whose selected features are used like a cookie cutter on the active layer. 
Everything that falls under the cutter feature(s) is erased. If a selection exists in the active layer only 
selected features are cut. In case a feature would completely disappear, a message is issued to the 
user, asking if this feature should be deleted. 

Clip with polygon from another layer 

applies to: line and polygon layer (multi or single part) 

Choose another layer whose selected feature is used like a cookie cutter on the active layer. 
Everything that falls under this feature will survive, everything outside will be erased. If a selection 
exists in the active layer only selected features will be clipped. 

Fill ring 

applies to: polygon layer (multi or single part) 

Fill rings (islands) in polygons with new features. This tool has two modes: 

1. batch mode: all rings in the selected features are filled with new features. The attribute set for 
all features is identical and can be entered once if form popup after feature creation is not 
suppressed. 

2. interactive mode: click into any the ring. A new feature is snuggled into the ring. 

Fill gap 

applies to: polygon layer (multi or single part) 

Fill gaps between the selected polygons of the active layer with new features. The algorithm has to 
union all selected features first, thus the selection is necessary to speed up the process, especially if 
the layer contains many features. This tool has two modes: 

1. batch mode: all gaps between the selected features are filled with new features. The attribute 
set for all features is identical and can be entered once if form popup after feature creation is 
not suppressed. 

2. interactive mode: click into the gap to be filled. A new feature is snuggled into the gap. 

Fill gap (all visible layers) 

applies to: polygon layer (multi or single part) 

Fill gaps between the polygons of all visible layers with a new feature: click into the gap to be filled. A 
new feature is snuggled into the gap. 
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Split selected features with selected line from another layer 

applies to: line and polygon layer (multi or single part) 

Splits all selected features of the active layer with the selected line feature of another layer. The 
splitting creates new features (not multi features). Each new feature resulting from being split retains 
its original attributes. 

Flip line 

applies to: line layer (multi or single part; does not make too much sense with multi part, though) 

Flip the direction of a line, i.e. reverse the node order within the line. This tool has two modes: 

1. batch mode: all selected lines are flipped. 
2. interactive mode: click any line feature to have it flipped (successful clicking depends on 

layer's snap settings). 

 

Favourites 

To add a directory as a Favourite for quick access, right click on the “Favourites” item in the 

Browser panel, then add directory. The favourite directory will then make it much quicker to access 

commonly used files. 

Point Sampling of Raster Data 

The quickest method to populate drill hole RL’s for example, is to use the “v.what.rast” algorithm. 

This algorithm can update fields in an existing table. 
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The Point Sampling plug-in tool can also be used to sample points in a grid, e.g. drill hole collar 

elevations using a digital elevation grid. The output creates a separate file with the resulting 

values. The point and grid layers need to be in the same projection. The tool is found under the 

Plugin > Analysis > Point Sampling Tool. 
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Select the layer containing the points to be used for the data extraction (drill  holes), then select 

the fields to be exported with the points (Hole number), and then select the layer with the elevation 

data (e.g. dem-9s:Band 1). This will then create a file with hole number and elevation.  This will 

then need to be joined to the drill collar file for example. I find it quicker to use the v.what.rast 

algorithm above, as this automatically undated the data field. 

Profile Tool 

This plug-in allows the user to put a line across a grid and obtain a profile along the line.  

Points to Lines and Polygons 

To create a line or polygon from a list of coordinates, for example an excel spreadsheet with 

tenement corners, use the Processing Toolbox > SAGA > Vector Line Tools > Convert Points to 

Lines and/or Convert Lines to Polygons. 

QPackage 

The QPackage plug-in allows the user to create a project file with an associated folder holding all 

the relevant layers for that project. Note that this will only copy vector files. 
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Quick Rectangles, Circles, Ellipse Shapes 

The Shape Digitising tool bar allow the creation of vector shapes, e.g. rectangle and circles. 

 

Refactor Field 

The Refractor Field algorithm allow the modification of a tables ’ attributes. Be careful using this! 

 

Note the fields with way too many decimals. These can be fixed using the Processing Toolbox > 

Vector General > Refactor Fields. 

 

Field names, types and other info can be changed in this window. 
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Selecting Drill Holes by Tenement 

To select drill holes in a tenement, simply highlight the drill hole layer in the Layers panel, then in 

the top menu bar choose, select Features by polygon, then right click on the polygon you want to 

use to select the drill holes, the select layer (e.g. tenements layer) will be listed, just select that 

layer and the holes will selected for that tenement. Note this may not worked with layers in different 

projections. 

 

The other method that can be used is the Processing Toolbox > Vector Selection > Select by 

Location algorithm. 

 

 

If you hold the "Alt" key while making a selection QGIS, it switches from an "intersects" type 

selection to a "contains" selection mode. (This also works while holding the shift modifier to add 

to a selection, or ctrl to subtract from a selection!). 

 

Spatialite Databases 

A Spatialite database is a simple, single file database structure that can hold very large files but 

with the advantage that the data is spatially referenced. The spatial referencing allows the data to 

be quickly displayed when panning across a map. This is very useful for data such as the  250k 

vector data (from GA) for Australia or the large GSWA open file drill hole database.  
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The use of Spatialite database files can rapidly increase the speed of accessing large data sets. 

As an example, the entire 1:250 000 Geoscience Australia Australia-wide topographic vector data 

in zipped shapefile format is 1.01 Gb in size (GA file 64058.zip) and comprises many layers 

including road, rivers, etc. This file can be loaded into a Spatialite database file of about 3 Gb, but 

although a large file, the data is spatially indexed, and re-drawing of the data is very fast when 

panning from area to area.  

Another spatialite option is to use the new GeoPackage file format which can store large datasets 

comprising vector, raster and non-spatial data. 
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A–37–1

37.1—Sedimentary-rock lithologic patterns

37—LITHOLOGIC PATTERNS
[Lithologic patterns are usually reserved for use on stratigraphic columns, sections, or charts]
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601
Gravel or

conglomerate
(1st option)

602
Gravel or

conglomerate
(2nd option)

603
Crossbedded gravel

or conglomerate

605
Breccia (1st option)

606
Breccia (2nd option)

607
Massive sand or

sandstone

608
Bedded sand or

sandstone

609
Crossbedded sand

or sandstone
(1st option)

610
Crossbedded sand

or sandstone
(2nd option)

611
Ripple-bedded sand

or sandstone

612
Argillaceous or

shaly sandstone

613
Calcareous
sandstone

614
Dolomitic
sandstone

616
Silt, siltstone,
or shaly silt

617
Calcareous

siltstone

618
Dolomitic
siltstone

619
Sandy or silty

shale

620
Clay or clay

shale

621
Cherty shale

622
Dolomitic shale

623
Calcareous shale

or marl

624
Carbonaceous

shale

625
Oil shale

626
Chalk

627
Limestone

628
Clastic

limestone

629
Fossiliferous clastic

limestone

630
Nodular or irregularly

bedded limestone

631
Limestone, irregular
(burrow?) fillings of

saccharoidal dolomite

632
Crossbedded

limestone

633
Cherty crossbedded

limestone

634
Cherty and sandy

crossbedded
clastic limestone

635
Oolitic

limestone

636
Sandy limestone

637
Silty limestone

638
Argillaceous or
shaly limestone

639
Cherty limestone

(1st option)

640
Cherty limestone

(2nd option)

641
Dolomitic limestone,

limy dolostone, or
limy dolomite

642
Dolostone or

dolomite

643
Crossbedded
dolostone or

dolomite

644
Oolitic dolostone

or dolomite

http://pubs.usgs.gov/tm/2006/11A02/ai8/FGDCgeostdTM11A2_A-37-01ai8.eps
http://pubs.usgs.gov/tm/2006/11A02/cs2/FGDCgeostdTM11A2_A-37-01cs2.eps
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37.1—Sedimentary-rock lithologic patterns (continued)

37—LITHOLOGIC PATTERNS (continued)
[Lithologic patterns are usually reserved for use on stratigraphic columns, sections, or charts]
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652
Fossiliferous rock

653
Diatomaceous

rock

654
Subgraywacke

655
Crossbedded
subgraywacke

656
Ripple-bedded
subgraywacke

657
Peat

658
Coal

645
Sandy dolostone

or dolomite

646
Silty dolostone

or dolomite

647
Argillaceous or
shaly dolostone

or dolomite

648
Cherty dolostone

or dolomite

649
Bedded chert
(1st option)

650
Bedded chert
(2nd option)

651
Fossiliferous
bedded chert

659
Bony coal or
impure coal

660
Underclay

661
Flint clay

662
Bentonite

663
Glauconite

664
Limonite

665
Siderite

666
Phosphatic-nodular

rock

667
Gypsum

668
Salt

669
Interbedded

sandstone and
siltstone

670
Interbedded

sandstone and
shale

671
Interbedded ripple-
bedded sandstone

and shale

672
Interbedded shale
and silty limestone
(shale dominant)

680
Interbedded

limestone and
calcareous shale

681
Till or diamicton

(1st option)

682
Till or diamicton

(2nd option)

683
Till or diamicton

(3rd option)

684
Loess (1st option)

685
Loess (2nd option)

686
Loess (3rd option)

673
Interbedded shale

and limestone
(shale dominant)

(1st option)

674
Interbedded shale

and limestone
(shale dominant)

(2nd option)

675
Interbedded calc-
areous shale and
limestone (shale

dominant)

676
Interbedded

silty limestone
and shale

677
Interbedded

limestone and
shale (1st option)

678
Interbedded

limestone and
shale (2nd option)

679
Interbedded

limestone and shale
(limestone dominant)

http://pubs.usgs.gov/tm/2006/11A02/ai8/FGDCgeostdTM11A2_A-37-02ai8.eps
http://pubs.usgs.gov/tm/2006/11A02/cs2/FGDCgeostdTM11A2_A-37-02cs2.eps
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37.2—Metamorphic-rock, igneous-rock, and vein-matter lithologic patterns

37—LITHOLOGIC PATTERNS (continued)
[Lithologic patterns are usually reserved for use on stratigraphic columns, sections, or charts]
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717
Basaltic flows

718
Granite (1st option)

719
Granite (2nd option)

720
Banded

igneous rock

721
Igneous rock
(1st option)

723
Igneous rock
(3rd option)

724
Igneous rock
(4th option)

725
Igneous rock
(5th option)

726
Igneous rock
(6th option)

727
Igneous rock
(7th option)

728
Igneous rock
(8th option)

722
Igneous rock
(2nd option)

711
Tuffaceous rock

712
Crystal tuff

713
Devitrified

tuff

714
Volcanic breccia

and tuff

715
Volcanic breccia
or agglomerate

716
Zeolitic rock

729
Porphyritic rock

(1st option)

730
Porphyritic rock

(2nd option)

731
Vitrophyre

732
Quartz

733
Ore

707
Schist and gneiss

708
Gneiss

709
Contorted gneiss

710
Soapstone, talc,
or serpentinite

701
Metamorphism

702
Quartzite

703
Slate

704
Schistose or

gneissoid granite

705
Schist

706
Contorted schist
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38—EXPLANATION FOR PATTERN CHART
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DESCRIPTION
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Pattern is in front. One bounding box (having Fill and Stroke set to 'None') is in back

K, black; C, cyan; M, magenta; DO, dropout; R, red; B, brown

White background is transparent (underlying map-unit color will be visible)

Black background represents underlying map-unit color. If white pattern is used "as is," it will
knock out the underlying map-unit color; if pattern is changed to one of the CMYK values in
the underlying map-unit color, it will knock out the other CMYK value(s) in map-unit color

Overprint patterns have white background

Dropout patterns have black background

Abbreviations used in pattern numbers:

Pattern is in front. Two bounding boxes are in back: box directly beneath pattern has Fill set
to 100% black and Stroke set to 'None'; box to rear has both Fill and Stroke set to 'None'

This diagram provides some basic information on how to use the new Pattern Chart, which is enclosed in the sleeve on the inside back cover of 
this standard volume. For more specific information on the use of patterns (and color) on geologic maps, see Section 5, entitled "Guidelines for 
Map Color and Pattern Selection," in the accompanying introductory text.
Most patterns on this new chart were designed (in Adobe Illustrator 8.0.1) to closely replicate patterns in the informal "Technical Cartographic 
Standards" volume (U.S. Geological Survey, ca. 1975). In some cases, however, lineweights of pattern elements had to be increased to facilitate 
higher resolution (1800 dpi) digital output; therefore, some patterns may not plot or print correctly if output at lower resolutions.
Each pattern has been assigned a new pattern number (see below each box). In addition, each pattern now has associated with it a generic 
look-up table number that can be used to access a pattern if it has been incorporated into a patternset.

IGNEOUS PATTERNS (Series 300)

301-M 301-DO301-C301-K

302-K 302-C

304-C

305-K

306-K 306-C 306-M 306-DO

305-C 305-M 305-DO

304-M 304-DO304-K

302-M 302-DO 

303-K 303-C 303-M 303-DO

301 302 303 304

305 306 307 308

309 310 311 312

313 314 315 316

317 318 319 320

321 322 323 324

Pattern number
shown below box

Generic lookup-table number
shown in upper left-hand

corner of box (can be used
to access a particular

pattern from a patternset)

http://pubs.usgs.gov/tm/2006/11A02/ai8/FGDCgeostdTM11A2_A-38-01ai8.eps
http://pubs.usgs.gov/tm/2006/11A02/cs2/FGDCgeostdTM11A2_A-38-01cs2.eps
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