
Consider a bowl. Its volume can be found by delineating two things: a plane across its rim and its curved inner
surface. Finding the volume of a watershed is much the same. A capping surface can be constructed by
connecting a set of points located along the divide, while the inner surface is the modern topography represented
by the DEM. The volume is simply the difference between the cap elevation and topography. “Minimum Eroded
Volume” is called “Minimum Bulk Erosion (E )” by Bellin et al. (2014), but its hopeless getting through to the
Belgians (#Piorot).

0.) Workflow Overview
Detailed instructions are provided below, but the the general workflow goes like this:
Define the rim (watershed boundary polygon) –> Convert polygon to points –> Extract elevations of points –>
Create a capping surface (a TIN) from points –> Convert TIN to raster –> Subtract the modern topographic surface
from the cap surface –> Calculate the volume –> Convert units to km .

1.) Getting Started
– If you have already completed the Watershed Delineation lesson, use those files and skip down to Step #2. Recall
that the filenames used here are just suggestions; yours may differ.

– Start with a projected, filled DEM and the watershed boundary polygon shapefile (ws1_boundary). TIN creation
(Step #6) requires a projected coordinate system and map display units in meters or feet. Alternatively, you could
change the Data Frame to a projected coordinate system (View menu > Data Frame Properties > Coordinate
System tab…select a projected coordinate system; Change the map units too, in the General tab).

– Open Attribute Table for watershed boundary polygon shapefile. Mine is named ws1_boundary. Add a New Field,
formatted Float, named “Area”. Right-click > Calculate Geometry (Area) for the polygon in km .

– Clip DEM to watershed boundary:
Data Management > Raster > Raster Processing > Clip tool
Input raster = DEM
Output extent = ws1_boundary
Click the box for “Use input features for clipping geometry”
Leave NoData value at the default
Output = ws1_dem
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Make sure to save output raster in correct folder

– You should now have a DEM for just the watershed (ws1_dem) and one for the whole area (DEM). Keep both in
your .mxd for now.

2.) Convert Basin Polygon to Point File
– Data Management tools > Features > Feature Vertices to Points
Input = ws1_boundary
Output = rimpoints
Point Type = ALL
Click OK

4.) Extract Rim Points Elevation Values from the DEM
– Use the full DEM as the input for this step, not the one clipped to the watershed boundary. By ‘full’ I mean a DEM
that overlaps and is larger than your watershed boundary polygon:
Spatial Analyst Tools > Extraction > Extract Values to Points
Input point features = rimpoints
Input raster = DEM
Output point feature = rimpoints_extracted
Check the box “Append all the input raster attributes to the output features”
Click OK

– When complete, check to see if the Attribute Table of rimpoints_extracted contains the extracted elevation values.
They will be in field called RASTERVALU. You will use this shapefile and this field as the inputs to your capping
surface (TIN).

– Remove the original rimpoints layer from the TOC.

5.) Turn on the 3D Analyst extension (Customize > Extensions)

6.) Create TIN Surface
– TIN = Triangular Irregular Network

– 3D Analyst Tools > Data Management > TIN Management > TIN > Create TIN
Output TIN = ws1_tincap
Spatial Reference = Make sure your coordinate system is a projected one – matched to the C.S. you set for the
Data Frame earlier (see Step #1)
Input feature class = rimpoints_extracted
Click in the first cell of each of the following columns and change what’s there.
Make sure you choose from the drop down list that will appear once you click on it:
height_field = RASTERVALU
SF_type = masspoints
tag_field = <none>
Click OK
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– When complete, a TIN should appear. It represents a theoretical pre-erosion cap surface for the watershed, as
defined by rimpoints_extracted.

7.) Convert TIN to Raster
– 3D Analyst Tools > Conversion > From TIN > TIN to Raster
Input = ws1_tincap
Output raster = ws1_caprast
Output Data Type = INTEGER
Method = LINEAR
Sampling Distance = set to CELLSIZE (cellsize should match that of ws1_dem or DEM; check Properties > Source)
* Z Factor = 1 (see note at bottom of page)

– Turn off the TIN layer.

8.) Clip Raster to Basin Boundary
– Use ws1_boundary as cookie cutter to clip cap raster to the boundary of your watershed.

– Data Management Tools > Raster > Raster Processing > Clip
Input raster = ws1_caprast
Ouput extent = ws1_boundary
Click the box for “Use input features for clipping geometry”
Output = ws1_capclip
Click OK

9.) Calculate Difference Between Clipped Cap and DEM Topography
– Spatial Analyst > Map Algebra > Raster calculator, use buttons to create the script below. It may seem like you
should use ws1_dem instead of the larger DEM, but it just works better if you don’t.
Output = ws1_diff
Double-click on the layer names, single click on the operator buttons:

“ws1_capclip” – “DEM”

10.) Find Pixel Count and Pixel Area
– Right-click on the ws1_diff raster, Properties > Symbology > choose Classified in left-side frame > click Classify
button, find the SUM in the Classification Statistics box at upper right. It might seem like you should use COUNT,
but don’t. SUM is the number of pixels in the difference raster- a number in the millions. Write this number down.

– Find pixel dimensions in Properties > Source > Cellsize of your original DEM (not the difference raster). Write this
number down – you’ll use it in the next step.

Example Pixel Area Calc
27.33m x 27.33m = 746.93 m

** IMPORTANT NOTE: The DEM data I provide my students is likely 30m resolution, which in this
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example is 27.33m resolution due to the particular latitude location and projection we use. ArcGIS,
however, may show the cellsize (Properties > Source) to be something unusually small (i.e., 0.00027.33).
This number must be reinterpreted. Since you know its a 30m DEM, read it as 27.33 (or whatever makes
sense with the specific values shown in Source tab for your data). Do not use the tiny number. I think
this problem is specific to ASTER DEM data from USGS EarthExplorer website, but still not sure. If
anyone knows a fix, please write me.

11.) Calculate Minimum Eroded Volume

SUM x Area of a Single pixel = Volume in m

Example
(1,056,785) x (27.33)

– Report the minimum eroded volume to 2 decimal places in cubic kilometers (00.00 km ).

Example Calculation for Watershed #1
Watershed boundary polygon = ws1_boundary
Watershed DEM = ws1_dem
Full DEM = DEM
TIN = ws1_tincap
Raster = ws1_caprast
Clipped raster = ws1_capclip
Difference raster = ws1_diff

Example Calcs
SUM = 1,056,785
DEM pixel size = 27.33m x 27.33m = 746.93 m
Calculate volume –> (1,056,785.99)(27.33)(27.33) = 789,418,395.51 m
Convert units from m  to km  –> Divide m  by 1,000,000,000 (one billion) to get km
Minimum Eroded Volume = 0.79 km

12.) Optional: Use Google Earth to check out what your watershed looks like

13.) Optional: Calculate Ratio of Volume to Area (See RVA lesson)

14.) Repeat Steps for Additional Watersheds

Pixel Size Change After TIN-to-Raster Conversion from ESRI ArcDesktop Help
The Z-Factor variable is used to convert the z-units of the output raster. The
output heights are multiplied by this value. A default Z Factor variable is
calculated to convert the z-units to the same unit of measure as x,y if, and only
if, x-, y-, and z-units are defined in the spatial reference of the input TIN and
are standard projected units (for example,. meters, feet). If x-, y-, and z-units
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are the same, a value of 1.0 is used. If any of the units are undefined, a value of
1.0 is used. When there's no output extent defined in the Geoprocessing Analysis
Environment, the extent is calculated from the TIN, ensuring the entire data area is
covered by the output raster. In this calculation, the lower left origin of the TIN,
based on its rectangular extent, is used as the cell center of the lower left raster
cell. In raster space, a cell's location is the lower left corner of the cell,
rather than cell center. It may appear the output raster's extent exceeds that of
the input TINs. When there's an output extent defined in the Geoprocessing Analysis
Environment, the TIN To Raster tool uses the origin of the specified extent as the
lower left cell boundary for the output raster. This is for consistency of behavior
with other raster tools and facilitates use of a snap raster. The X and Y max values
of the output raster are then determined by using the origin plus the cellsize
specified in the TIN To Raster tool to see how many rows and columns fit within the
user-specified extent. Therefore, the actual X and Y max values of the output might
not exactly match the user-defined values if width or height of extent is not evenly
divisible by cellsize.

Refs:
Bellin et al. (2014) EPSL 390 p. 19-30
Gianconia et al. (2012) Geomorphology 145-146 p. 90-106
Menendez et al. (2008) Geomorphology 102, p. 189-203
Keller (1986)
Abbott et al. (1997)
Frankel (2002)
Frankel and Pazzaglia (2005)
Wobus et al. (2003)
Wobus et al. (2006b)
GISTutorials Video – Extract Raster Values to Shapefile in ArcMap
GISTutorials Video – Locating the Raster Calculator and Other Tools in ArcMap 10
Search terms for ArcGIS Resource Center (help.arcgis.com): TIN to Raster, Fundamentals of Surfaces, Terrain

More Volume-related Metrics

Volume of Lake Basin
Erika Akin GIS Technician, USGS/USFWS Landscape Conservation Cooperative
Skye Cooley G4G Editor

GENERAL OVERVIEW
In order to measure the volume of a dry lake basin using a DEM, a lake shoreline contour must be found, the DEM
clipped to this extent, and the elevation difference between modern topography and a lake surface raster
calculated. A simple unit conversion completes the process. In this example, we use a 30m DEM and a shoreline of
1500m ASL. We assume the lake has simply dried up (no erosion of sediment, no new sediment added). Additional
work to reconstruct the shape of the former lake basin would need to be completed if incision or infilling has
occurred since the time the lake drained. This method is similar to RVA (see ‘RVA’ post).
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Lake Basin Instructions
1.) Downloaded DEM from the National Elevation Data Seamless Server website (http://seamless.usgs.gov/) or
other source.

2.) Project the DEM (Data Management Tools > Projections and Transformations > Raster > Project Raster).

3.) Fill the DEM (Spatial Analyst Tools > Hydrology > Fill tool)

4.) Delineate the basin boundary (Spatial Analyst > Surface > Contour List > enter 1500). The unit of elevation for
most DEMs is meters. Check Properties > Source if there’s a question.

5.) If the contour does not completely enclose the lake basin, edit the polyline/polygon (Editor toolbar) to ensure
that it does.

6.) Use the polygon to clip the DEM (Data Management > Raster > Raster Processing > Clip).

7.) Convert the polygon to Points (Data Management > Features > Feature Vertices to Points). Consider thinning or
simplifying the polygon if the number of vertices slows processing.

8.) Extract the elevation of shoreline points and append these values to the point attribute table (Spatial Analyst >
Extraction > Extract Values to Points or Extract Multiple Values to Points).

9.) In 3D Analyst, create a TIN surface (3D Analyst Tools > TIN Management > Edit TIN) using the extracted points
as input feature class. Elevations will appear in a new field called RASTERVALU.

10.) Change height field to RASTERVALU, set SF-Type to Masspoints, and run the tool.

11.) Convert the TIN to Raster (3D Analyst > Conversion > From TIN > TIN to Raster) with Output data type as
Integer, Method as Linear, Sampling distance as Cellsize.

12.) Clip TIN raster to lake polygon (Data Management > Raster > Raster Processing > Clip). Make sure to the
check the little box.

13.) Calculate the difference between the plane of the former lake surface (TIN) and modern topography (DEM)
using Raster Calculator (Spatial Analyst > Map Algebra > Raster Calculator).

14.) Calculate the volume by first finding the total number of pixels between the two surfaces. Right-click raster >
Properties > Symbology > Classified, click Classify button, in the Classification Statistics at upper right locate the
Sum value. Multiple the Sum by the area of a single pixel. This gives you cubic meters. Make sure you check the
Properties > Source > Cell size of your DEM; cell size varies with latitude and projection.

15.) Convert m3 to km3 for final volume.
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RVA – Ratio of Volume to Area

RVA is the ratio of 3D volume (V) of a watershed to its 2D planimetric area (A). It is found after you have calculated
the volume of a basin (see Minimum Eroded Volume or Lake Basin Volume). The index is a means to compare
groups of watersheds in different phases of development. RVA is useful in comparing the relative effects of uplift
and denudation in a tectonically stable mountain range versus one actively uplifting. Report RVA values to 2 decimal
places for each watershed.

Refs:
Frankel and Pazzaglia (2005)
Frankel (2002) MS thesis at Lehigh University
Granger et al. (1996) Journal of Geology 104
Kirchner et al. (2001) Geology 29
Schaller et al. (2004) Journal of Geology 112
? Small et al. (1997) Earth and Planetary Science Letters
von Blankenburg et al. (2004) Journal of Geophysical Research 109

 

Volume of an Alluvial Fan
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