
MJKZZ StackRail Control Application For Windows

Version 2.11 User Manual

Overview

This is MJKZZ StackRail Control Application for Windows, version 2.11. This 

application allows you to control, set parameters for MJKZZ focus 

stacking rail. 

MJKZZ USB controller is a very versatile controller that allows user to 

have complete control over a rail, such as microstepping, power settings, 

etc. These features work in tandem to make the system work better.

Operation

Connecting To Rail

To connec to a rail, make sure the USB cable is plugged in and the USB 

controller is powered up , 

Plugging the USB cable is NOT enough, powering up the USB controller is also 

important as it will allow the controller to communicate with computer.  This 

is where many users make mistake at.

Moving The Rail

Once connection to USB controller is made, it is time to set range for the rail 

to move around and be bounded. To prevent accidental moving the rail out of 

boundary of physical ends, 

Setting Range - We ultilize a mechanism that prevents this sort of thing: 
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Press and hold the left SHIFT key while moving the rail by press UP or DOWN 

arrow keys to set the RANGE. Without doing this, upon first powering up and 

initial usage, the rail will NOT move because the RANGE is ZERO, it will beep.

Moving Rail - After range is set, press and hold UP or DOWN arrow key will 

move the rail in the desired direction. 

Moving Rail by Full Step - to move the rail up or down by a full step size, use 

Page Up or Page Down key to do so. These two keys will produce precisely a 

full step forward or backward.

Moving Rail to Start or End Position - press LEFT or RIGHT arrow key will 

move the rail to either Start Position or End Position, this is a great way to 

double check both end before start stacking.

Main Screen

2



Step Size / DoF  - This is where the optical system being used determines 
the value -- depth of field of the optical system. Most of the time, this value 
should be a little less than actual depth of focus. Use our depth of field 
calculator to determine this. Use the up or down arrow to change its value. 
Or press INSERT key or SHIFT ">" key on keyboard to increase its value or DEL 
key or SHIFT "<" to decrease its value. These short-cut keys are very 
convenient to use without using mouse, particularly for the supported mini-
keyboard (see more below)

Current Pos - This indicates where currently the rail is expressed in 
millimeters. 

Start Pos -- This is the starting position for stacking. Move the rail where 
focus stack starts, then press the "Set" button next to it. Or simply press F3 
on the keyboard so that no mouse is involved.

End Pos - This is the end position for stacking. Move the rail to where focus 
stack should end, then press the "Set" button next to it. Or simply press F8 on 
the keyboard without using a mouse.

Actual Step Size - this is the parameter that indicates actual step size is 
used. It is different from "Step Size / DoF" because  the smallest step size a 
rail can make depends on the rail used, microstepping parameter, and 
motor used. For example, with our belt driven rail, the smallest step is 
18.75um when microstep is set to 8th. This means if DoF is less than 18.75um, 
it is likely not going to work with an optical system whose DoF is 10um, in this 
case, our lead screw driven rail will be needed. So please watch out this 
value and DoF of your optical system.

Count - this is how many images will be taken when focus stacking process 
starts. Notice that there will always be one image at start and at end 
position.
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Distance - this is how long, in millimeters, the depth of stack is. 

Frame Position - This is the frame where the rail is at or between.

Stack - this is the button to start or stop stacking process. Alternatively, 
press SHIFT ENTER will also start or stop the stacking process without using 
a mouse to click that button.

Parameter Screen

This screen can be brought up by going to Menu Tools->Setup.

Wait - this is the parameter for how long the controller should wait before
taking a picture after moving the rail. This parameter is necessary to let 
vibration caused by moving the rail to settle so that when capturing an 
image, it will be as less vibration as possible.
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Hold - this is the parameter to determine how long the controller should 
hold after taking a picture. This is necessary if long exposure is used. For 
example, if exposure time is one second, then the controller should hold at 
least one second before any movement of rail, else moving the rail during 
expsoure will ruin the image

Snap - this is the parameter to determine how long the controlle should hold 
the electronic signal down for camera to take a picture. Some camera needs 
a little more and some needs less. The best practical value is 200ms, but it 
varies from camera to camera and adjust it accordingly.

Reverse Direction - this parameter is mostly for those who build their own 
rails and electrical sigal for the step motor might be different. This 
difference in electrical wiring of step motor might cause the motor move to 
the opposite direct than intended. For example, press UP arrow actually 
moves the rail backward. So by checking this option, the direction will be 
reversed.

Power - this is the power supplied to the motor when it is running. Most step 
motor power is rated by how much current is supplied. Most of the time, 1.0A 
current is more than enough to move all rails by MJKZZ

Idle - this is the idle power supplied to the step motor when it is NOT running 
and has been idle for over 10s. It is possible to set this value to be the same 
as Power parameter if idle power saving is not needed. Setting this 
parameter to the same as Power is particularly important when setting up 
vertical setup. For some highly efficient rails, such as MJKZZ Ultra Rail, 
when no power or less power supplied, under the weight of load, it might 
move, so it is important to set this value to higher.

Pitch - this is the parameter that should match what rail is used, it varies 
and must be set accurately, else the display on the first main screen will not 
be accurate, Please consute rail supplier.

Turns/Rev - this is referred to step motor used. Most step motor needs 200 
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steps to make a full revolution, so needs 400 steps. Please consult the rail or 
motor supplier.

Micro Step - this is how a step motor controller sub-divides a full step into 
micro steps. Early MJKZZ USB controllers can do the following: 4th, 8th, and 
32nd, newer MJKZZ USB controllers (firmware 2.0 and above) can make 4th, 
8th, 16th, 32nd, 64th, and 128th micro steps. Further increase stepping 
resolution. You do not have to use this parameter screen to change this 
parameter, simply use keyboard to change it: press F ast to set to 4th micro 
step mode, press M edium to set to 8th micro step mode and press S low to 
set to 32nd micro step mode. 

Important note, after changing parameters, they are not saved automatically 
because the changes could be temporary. To permenantly save the changes, 
plese use menu File->Save.

Localizing This Application

This application can be localized to your own language if you wish. Under memu 
Help->Language->Export, a file will be generated containing all entries and words 
used in the application. Simply changing what is inside the double quote for every 
entry,save the file. Then use menu Help->Language->Import function to import your 
translated file, it will restart the application and that is it.

Calculator

There are five different calculators that essentially calculates step size based on 
different lens system. Step size calculation is based on circle of confusion and 
there is 20% safety margin applied.. Here are list of values for each sensor type:

⦁ APS (Canon), this is for most of Canon crop frame cameras, like 550D (T2i), 60D, 

etc. 

⦁ APS (Nikon/Pentax/Sony), this is for most of other type of APS sensors, mostly 

used by Nikon, Pentax, or Sony, 
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⦁ Full Frame, this is for all full frame cameras. 

⦁ Micro 4/3, this is mostly for Olympus, Panasonic cameras where Micro Four 

Third sensor is used.

All calculators will calculate magnification (in case it is provide, as in objective, it 
is simple taken from there), effective aperture, and step size.

Estimating Step Size when Microscop Objective is used.

This is to calculate step size when an objective is used. 

⦁ Objective NA -- this is the Numeric Aperture value, usually marked on the body 

of objective. 

⦁ Objective Magnification -- this is the magnification the objective is designed for 

when used according to its specification. If the objective is not used according 
to its specification, this should be the ACTUAL magnification in use. For 
example, a Mitutoyo 10X 0.28 and 200mm objective can be used with 180mm 
tube lens, in this case, the actual magnification is 180/200 * 10 = 9x

CloseUp Filter Lens System

This calculator is used for a lens system when a close up filter is used on front of a 
primary lens -- it could be a normal lens, a zoom lens, or a macro lens (where 
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Primary Lens Magnification can be very high, such a 1x). The calculation also take 
extension into consideration.

⦁ Dioptor Value -- this is the dioptor value of the closeup filter. Normally this is 

specified by closeup manufacture, usually in form of +1, +2, +3, +4, +8, +10, etc. 

⦁ When using multiple closeup filters, simply use the sum of all dioptor value for 

this entry.  In case this value is NOT specified, here is a list of commonly used 
closeup filter and their dioptor values. 

⦁ Primary Lens Focal Length -- this is the actual focal length used with the 

closeup filter. In case of zoom lens, enter the actually zoom value.

⦁ Primary Lens Magnification -- this is the actual magnification value for the 

primary lens. In case of the primary lens is a macro lens, be careful to use 
ACTUAL magnification -- most macro lens provides maximum magnification, 
for example 1x,  when focused to closest point. 

⦁ Extension Tube Length (mm) -- this when an extension tube is used in addition to 

closeup filter.. If no extension tube is used, simply enter zero

⦁ F-Stop -- this is the aperture used on the primary lens. This will affect the 

effective aperture.
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Lens With Extension

This calculator calculates a single lens on an optional extension tube. If a lens 
already has enough magnification power, such as Canon MP-E 65, and does not 
have extension tube added, simple enter zero for Extension Tube Length.

⦁ Primary Lens Focal Length -- the actual focal length for the lens, in case of a 

zoom lens, read it from the lens barrel.

⦁ Primary Lens Magnification -- this is the actual magnification used on the lens. 

In case of some macro lens, such as Canon MP-E 65, there are magnification 
marking on them.

⦁ Extension Tube Length (mm) -- this is the length of extension tube measured in 

millimeters. Important note, if you do not have an extension, set this value to 
zero. For example with Canon MP-E lens, very often you do not need extension 
tube and still have a magnification of 1 to 5X.

⦁ F-Stop -- this is the actual aperture used on the primary lens.

Stacked Lenses

This calculator is for the lens system where two lenses are stacked together with 
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one is reversed on another. Most often, the front lens (ie reversed lens) has shorter 
focal length and the primary lens has longer focal length.

⦁ Primary Lens Focal Length -- this is the actual focal length set on the primary 

lens, in case of zoom lens, it can be read from lens barrel

⦁ Reversed Lens Focal Length -- this is the focal length of reversed lens.

⦁ Optional Extension Tube Length -- this is option and if no extension tube is used, 

simply enter zero

⦁ F-Stop -- this is the aperture set on the reversed lens. In a stacked lenses 

system, it is better to set the primary lens to wide open and use the reversed 
lens to control aperture.

Reversed Lens

This calculator is for a system when a lens is reverse mounted on a bellow or 
extension tube. 
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⦁ Reversed Lens Focal Length -- this is the focal length of reversed lens

⦁ Reversed Lens Magnification -- this is the magnification of reversed lens, for a 

normal lens, it is usually very small.

⦁ Extension Tube Length -- this is the length of extension, can be extension tube 

or bellow. Note, this includes flange distance -- for Canon EOS camera, flange 
distance is 44mm and for Nikon AI mount, it is 39mm. So, if the actual extension 
tube length is 150mm, for Canon, the extension is 150+44 = 194mm.

F-Stop -- this is the aperture set on the reversed lens

FAQ

Q: After connection all components together and powering up, the rail is not 
moving, why?

A: Please press and hold LEFT SHIFT key and UP or DOWN key to set moving range 
whenever you power up the units.

Q: When I set number of steps and without changing the default step size 
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afterwards, the result is a little weird, why?

A: This is caused by integer division. Here is an example, assume the rail has 2mm 
pitch and motor micro step is 1/8, this result in 1.25um resolution for step size. Now 
say after setting start and end position for stacking, the total stacking distance is 
442um and then set number of steps to 80, this will result step size as 5um because 
the actual step size is 5.525um, but the next integer step size is 6.25um. However 
this 5um step size is not enough for the rail to reach the final 442um. The solution is 
to change the step size manual to 5um (click up and then down on the arrow next to 
Step Size), this will make the number of steps to be 89, 88 steps of size 5 and one 
step of size 2um to make a total of 442um

Q: When I set rail for stacking, I have reach the range limit of zero (0), so I extended 
this range by press and hold SHIFT key and DOWN arrow key, but then my start and 
end position changed, what happened?

A: When you extend the zero limit side of range, your stacking position becomes 
invalid. It is highly recommended to set range limit whenever you power up the 
motor and its driver unit to their max extend. Or whenever you change the range, 
re-position the rail for stacking.

Q: F6 and F5 to focus and stop focus is not working?

A: Only firmware with version 1.0 or above have this function
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